Help

0

Odoo 13, not working after adding workers > 0 in odoo.conf file

Avatar
kevin lall

Hi, after I added the 'workers' parameters, odoo shows a blank page with the following console message, before posting or asking for help I spend much of the day researching this issue with no luck. 

GET http://192.168.16.17:8069/web/content/471-ec6974a/web.assets_common.js net::ERR_CONTENT_LENGTH_MISMATCH 200 (OK)

web:40 GET http://192.168.16.17:8069/web/content/472-82fd55d/web.assets_backend.js net::ERR_CONTENT_LENGTH_MISMATCH 200 (OK)

web:52 Uncaught TypeError: odoo.define is not a function

    at web:52


my config is

[options]

; This is the password that allows database operations:

admin_passwd = lGT2smYEp5L1BqJr

db_host = 192.168.16.17

db_port = 5432

db_user = odoo

db_password = *****

db_maxconn = 64

xmlrpc_port = 8069

max_cron_threads = 2

workers = 3

logfile = /var/log/odoo/odoo-server.log

addons_path=/odoo/odoo-server/addons,/odoo/custom/addons,/odoo/custom/test_dev

1 Commento
Avatar
Abbandona
Avatar
Sehrish
-
2 Risposte
0
Avatar
kevin lall
Best Answer

Hi, Sehrish and Ivan thank you for your response, I was able to resolve the issue, Ivan's link help to farther provide validation what I knew was the answer.

Workers parameter or Workers > 0 will not work without a reverse proxy.

once I set up the reverse proxy (Nginx), the above issue was resolved, hope that this will help others having this issue.

Avatar
Abbandona