Assistenza

0

Inventory and Manufacturing Issues

Avatar
Harmit

I am using Odoo 14V.
We set up inventory (location, stock, lot wise tracing), Manufacturing (Work centers, BoMs, Operations). The issue I'll describe with as instance. I have a 'product A', which has manufactured by 2 components [5 units' consumption of 'item1'], [1 unit consumption of 'item2']. Suppose 'item1' has been purchase 10 quantity with lot number '1001' and stored in internal location WH/Stock. 'item2' has been consumable type, so there is no required any quantity.
Once the MO complete, the result would be remain 5 units of 'item1' in storage location. But, I saw there is no deduction in 'item1', apart from that, one another product created in storage location with same name('item1') and same lot number('1001') with -1 quantity in same location.
It will so helpful if anyone have any idea to solve this.

Avatar
Abbandona
1Risposta
1
Avatar
Lars Aam
Migliore risposta

Some things you can check:

Did you check inventory report and available stock before processing the manufacturing order?  To confirm that Goods receipt was posted correct?

On your manufacturing order: Is status = Done?  Did you get any warning about consumption when you set Status Done?

On components you can see To Consume (Planned from BOM) and Actual consumed.

From manufcaturing order you can check Product Moves. It will show From To Location and qty.

Have you set up something special for for routes? 

Have you done anything special with UOM?

6Commenti
Avatar
Abbandona
Avatar
Harmit
-

Thank you for your replay,
Yes @lars Aam, I checked there was enough quantity available in stock.
There is no any warning on consumption. (the lot number is necessary to add, so I did the same lot number as I have that component in stock)
On components I can see the consumed numbers(Planned from BOM).
I check the product moves, it shows me the perfect transactions(Location and qty.).
No, I have not set up anything special for routes or UMO.

If its help, I tried one more time by adding items when OEE is running, but, I can not see my reserved stock qty. (I think, when I add lot numbers, its give me total numbers of remain time in that lot number but, it not)
Additionally, The Lot number have 10 qty. and I want to consume 5 qty. from that lot (for the knowledge), Is something with this can be made issue?

Avatar
Lars Aam
-

You describe a typical standard process.
I think if you can provide a video or screen shot (video is best) of all screen and the process. Include view of manufactuiring order after confirmation and the product moves.
And perhaps from Inventory->Configuration Operation type Manufacturing.
Then I might be ble to put you on the track for correction.

Avatar
Harmit
-

Sure, I made a video of the process. I tried on another same product. 'Sunflower'
you can see by click on this link https://www.awesomescreenshot.com/video/10269928?key=523a7f7b6126c0952dbc3c6c4f897ab4

Avatar
Lars Aam
-

As far as I could see, you did not enter any consumption of components in the manufacturing order. When you got the pop up that ask for confirmation of consumption, it showed 0 in consumed. Only planned consumption. So you confirmed that nothing was consumed.
Your component (Sunflower) also had tracing. So in the screen for consumption you must also enter the lot number for the component.

I noticed you enter the lot number for the product produced = to the lot number of your component. But the lot number you entered was only assigned to the product produced. (It is OK in Odoo to have the same lot number for two different product.)

Since you use work order, the normal prosess is to confirm produced and consumed in the work order. You did not open the work order. Only start and stop. Open the work order (click in the symbol out on the right, or go to the work order kanban overview (default view), and you will se clear where to enter lot number produced, and lot number consumed and how to confirm consumption.

Avatar
Lars Aam
-

BTW: Check setting in Manufacturing app: Lock Quantities to consume. And thre related parameter in BOM to set if Flexible consumption is allowed or not.

Avatar
Harmit
-

Thank you Lars Aam,
I forgot about Check setting in Manufacturing app: Lock Quantities to consume.
It's helpful, sometimes its just small thing we have and got frustrated.
Again, thank you sm for your time.