Community: CMS / eCommerce Experts mailing list archives


Re: Is Odoo storing .pyc files somewhere unusual?

Camptocamp SA, Yannick Vaucher
- 06/12/2014 19:03:18

pyc files must apear side to py files. Till version 8.0 you always need to stop and start your server to update them. In further version I think it is planned to reload python on module update. To be confirmed by odoo wizards.


Le 6 déc. 2014 02:27, "Darrel Grant" <> a écrit :
I partially figured this out. After changing the python code of a
module, and restarting the server using (sudo service odoo-server
restart), it wasn't picking up the changes. I have found that the
server was not actually stopping.

After killing it, it now seems to be restarting properly as it did
before. I'm still not clear on why I can't find the pyc files
anywhere, but as long as the server is restarting properly, it doesn't
really matter.


On Fri, Dec 5, 2014 at 4:44 PM, Darrel Grant <> wrote:
> Got another question about odoo today. It's an oddity that has kept me
> puzzled for quite a while now.
> When I update my module's python code, the code files themselves are
> updated, but the actual bytecode that odoo runs is not. So, I get a
> stack trace showing me an updated line in the source file even after I
> have fixed the problem. I know what caused the original error, but
> nothing I do seems to cause it to pick up my changed code. Yes, I have
> tried restarting the server.
> When I look in the module, it has .py files, but the .pyc files are
> missing. Where could they be?
> If anyone wants details of the exact error that began this, someone on
> stack overflow helped me figure that out, here:
> (
> I'm not sure whether odoo has some logic that copies pyc files or
> whether something mysterious in my setup (ubuntu server 14.04 and odoo
> v8) is causing those files to disappear.  Any ideas?
> Darrel

Post to: