Community: Framework mailing list archives

expert-framework@mail.odoo.com

Re: Testing in Odoo v8

by
Vauxoo S.A. de C.V., Moisés Augusto López Calderón
- 05/12/2015 09:32:09

You have a different error now.
Try it as Nhomar told you removing current database:
dropdb testdb_39

Change from
-i all
to the list modules that you want install explicitly
-i stock,account,sale
-i all just work in a database prevously initialized, but to run test correctly is recommended use a empty database with data demo in True.

And now, loglevel of test is debug.
Change from
--log-level=test
to
--log-level=debug

El may 12, 2015 12:12 AM, "Manuel Vázquez" <manuel@merchise.org> escribió:
Hi Moisés,

I've just removed the first line.  But the errors are still produced:

INFO testingdb_66ddc7ceb openerp.modules.loading: loading
base/tests/test_ir_rule.yml
INFO testingdb_66ddc7ceb openerp.modules.module:
openerp.addons.base.tests.test_acl running tests.
INFO testingdb_66ddc7ceb openerp.addons.base.tests.test_acl:
test_field_crud_restriction (openerp.addons.base.tests.test_acl.TestACL)
INFO testingdb_66ddc7ceb openerp.addons.base.tests.test_acl: `
Read/Write RPC access to restricted field should be forbidden
ERROR False openerp.addons.base.tests.test_acl: ERROR
INFO False openerp.addons.base.tests.test_acl:
test_field_visibility_restriction
(openerp.addons.base.tests.test_acl.TestACL)
INFO False openerp.addons.base.tests.test_acl: ` Check that model-level
``groups`` parameter effectively restricts access to that
ERROR False openerp.addons.base.tests.test_acl: ERROR
INFO False openerp.addons.base.tests.test_acl:
test_fields_browse_restriction (openerp.addons.base.tests.test_acl.TestACL)
INFO False openerp.addons.base.tests.test_acl: ` Test access to records
having restricted fields
ERROR False openerp.addons.base.tests.test_acl: ERROR
INFO False openerp.addons.base.tests.test_acl: ==========

Notice that the first logs do have the right testingdb DB but then, the
reported DB in the logs changes to False.



Le 11/05/2015 11:15, Moises Lopez a écrit :
> Remove your second command:
> openerp-server -d testdb_39 -i all --stop-after-init
> 
> Just use the third one:
> openerp-server -d testdb_39 -i all --stop-after-init --test-enable
> --log-level=test
> 

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-framework-62
Post to: mailto:expert-framework@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe