Community mailing list archives

community@mail.odoo.com

Re: 10ce bunch of weird issues with timesheets

by
XPANSA, Oleg Kuryan - Chief Technical Officer, Xpansa Group
- 11/15/2016 16:43:14
Arjan,

First of all for me images are not displayed form your mail, but from mail will try to answer your questions:
1) Yes, now timesheets are slightly different from what they were in v9. In v10 grid view is default one. Is it good or bad - it depends on your needs. Personally - I do not like that new view, but that are my needs. You may have different opinion.
2) That type of error on my version I do not have, maybe there is a bug - try to update Odoo to latest one (both Enterprise and Community versions)
3) Now timesheets are entered not against analytic accounts, but against projects (that are connected with analytic account). So if there is no project -you will not see it listed in timesheet.

On Wed, Nov 16, 2016 at 12:37 AM Arjan Duijs <arjanduijs@gmail.com> wrote:
I noticed the install of timesheets is a bit different between version 9 and 10.
in v9 the 'main' app was hr_timesheet_sheet, with a dependency of hr_timesheet.

It automatically installed the grid view

In v10 its the other way arround, the 'main' app is hr_timesheet but does NOT install the gridview hr_timesheet_sheet.

however if i install it manually in V10, it gives me two problems.
1)  when i go the the timesheet link in the menu it generates an odoo error: 
(tested on windows and linux with production data AND the demodata)

Odoo 

Odoo Server Error
Traceback (most recent call last):
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 638, in _handle_exception
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 675, in dispatch
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 331, in _call_function
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\service\model.py", line 119, in wrapper
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 324, in checked_call
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 933, in __call__
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\http.py", line 504, in response_wrap
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\addons\web\controllers\main.py", line 862, in call_kw
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\addons\web\controllers\main.py", line 854, in _call_kw
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\api.py", line 681, in call_kw
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\api.py", line 672, in call_kw_multi
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\models.py", line 5460, in onchange
  File "C:\Program Files (x86)\Odoo 10.0\server\odoo\models.py", line 5358, in _onchange_eval
TypeError: onchange_employee_id() takes exactly 2 arguments (1 given)
2) there doesnt seem to be a connection between timesheet and analytic accounts.
to reproduce:
manually created analiytic account:
Inline afbeelding 1
and the analytic account is not found
Inline afbeelding 2

anyone can confirm this? or explain why this is happening?
note: all analytic account settings are checked in accounting and the user ones

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe