Community mailing list archives

community@mail.odoo.com

Re: Proprietary modules for 8.0?

by
SISalp
- 10/21/2016 09:33:47
2016-10-21 15:00 GMT+02:00 Ondřej Kuzník <ondrej.kuznik@credativ.co.uk>:
> On 21/10/16 11:57, Dominique Chabord wrote:
>> Yes, you are correct.
>> This case has been reported many times already.
>> I think nothing will change and nobody will care because V8 is old version
>> now.
>
> The problem is that this puts the people buying and installing a module
> into potential legal trouble as well (they would be violating the terms
> of AGPL by running the two together and anyone with copyright in Odoo
> would be able to sue them).

yes, you are right :
- the risk is on users first
but I'm not sure you need any copyright to sue them.
I think anyone with FSF support would be easily entitled to do so.
Nevertheless I don't know anyone willing to spend money and time on
this.
I see a much bigger case in challenging OCA position to make AGPL
addons "compatible" with Odoo Enterprise. But for this one too, what
would be the motivation to break something which seems to be widely
accepted ?