Community mailing list archives

community@mail.odoo.com

Re: Don't Show DB list when go to domain

by
Apertoso, Jos De Graeve
- 09/24/2016 05:35:09

2016-09-23 6:23 GMT+02:00 MD Tanzilul Hasan Khan <ponkhi403@gmail.com>:
Thanks. It's working but now I can't see the other testing databses if I goto /web/database/selector . Only one DB shows there (the production one). If I want to go to different DB I need to change the conf file.

You can run a second odoo process on a different port with a different config file.

When there is only one database, or odoo is configured to find only one database, it runs in the so-called single-database mode.  That is what you need in order to avoid having external visitors getting the 'select database' screen.

For testing purposes, you are now cutt off from the "select database" screen.  In order to use test databases, run a second odoo instance, on a different port, or even better on a different machine.

Make sure that your users only use the production URL for the production DB and test URL for test DB's.  If you start mixing up, you will get into trouble with the POS ui not sending orders to the backend etc...


Be aware that the command-line option is 'db-filter' and the configuration key is 'dbfilter' !!  If in doubt, check your odoo source: openerp/tools/config.py


Regards,
Jos De Graeve - Apertoso business ICT


Guido Gezellelaan 16 - B-9800 Deinze - Belgium
 
Direct: +32 9 381 64 51
General:+32 9 381 64 50
Mobile: +32 475 54 68 80
mail/im/skype: Jos.DeGraeve@apertoso.be - apertoso