Community mailing list archives

Re: [Bitnami Community] [Odoo/OpenERP] PayPal doesn't work ODOO 9 0620

- 07/26/2016 13:28:02

I did a lot off test and any solution provided by Odoo doesn't work (the return page shop/confirmation is already settled into Python code, and the page can't be called from the return_url defined into the paypal environment)

the only way is to use reverse proxy Nginx with SSL, but it doens't work with MS Windows fine with vista and of course


Didier Lacombe
Tél  : 00 33 (0) 6 20 57 32 20
Fax : 00 33 (0) 4 78 42 11 58

2016-07-11 10:37 GMT+02:00 Jonathan Dawn <>:
Tried the command on the test server.. it seemed to install something (see attached word doc)
rebooted server and site is crashed with some error. cant access it.

So I took a snapshop of my main server.. and tried it there. I followed your instructions and was able to do the ./use_odoo. And then the gevent --upgrade command
This time it said already up to date. so I rebooted everything and now the webserver is crashed with a 500 error. So ill restore from the snapshot now.

Ill try more when I'm not totally sleepy. Thanks again
I am at the point where I will happily pay for assistance with this issue.


On Mon, Jul 11, 2016 at 3:01 AM, Jonathan Dawn <> wrote:
Damian, thank you, I am going to try what you suggested now.

On Mon, Jul 11, 2016 at 2:53 AM, dbo-odoo <> wrote:
July 11


Don't know where to post this other than here; if you have other reporting channels I didn't find them.

Anyway, it would seem that the Odoo stack install the gevent python library with version 1.0.1; our requirements are 1.0.2 or later (see our python libs requirements).

I think a simple pip install gevent --upgrade in the stack should solve this (it did install 1.1.1 in my tests); but I don't know who's maintaining the image (it's not us). Would be nice to bump the version in the stack.


Damien Bouvy
Odoo Technical Support

Previous Replies

July 9

Yep I have been through all the threads on github related to the issue, including that one!

I have engaged in some conversation via the odoo community mailing list.
I have read that some say it is related to the deployment and something related to a "reverse proxy"

Please note i'm not a developer, I have just learned what I have to get where I have so far. I knew nothing of python, apache, cloud servers until I set out to get this running. I have it all running great so far, except thus ONE issue

Could you have a look at the odoo community thread and perhaps interject where needed?
Well I can't even find the archives and replys, but I can forward the emails to you...

To unsubscribe from these emails, visit your user preferences.

To stop receiving notifications about this particular topic, click here.

Post to: