Community mailing list archives

Re: custom folder addons

Andi Becker
- 06/21/2016 22:15:30
1. What are actually your experiences in having many addons folders in favor of having only a few?

i.e. a structure like


where plugins get collected to certain tasks/features which always occure in similar sites with the same set of modules.


debranding (and access stuff - as base-tasks for all sites)
- access_apps
- access_restricted
- access_settings_menu
- base_technical_features
- hidden_admin
- ir_rule_protected
- web_debranding
- web_debranding_support
- web_login_background
- website_debranding
- website_login_background

probably there are more useful modules to get here.

2. What would be the best way to automate these installs?

3. What approach are you using to update them on a regular base. i.e. the debranding stuff gets over and over adjusted as things seem to be changing in Odoo to avoid that unbranding too. i.e. since a few weeks again all those Enterprise Features get again displayed in the backend!

4. Is there a performance problem by having the apps structured in "Packages" - any experience?


@Administracio - work like a pilot before getting to the runway for take off!

  1. check the folder permissions and owners!
  2. check the permissions and owners of your config file where you have entered the paths
  3. check how those paths have been separated - check for manual linebreaks (there shouldn't be any)
  4. if you are running over a proxy check if the folder is accessible or if it is blocked!
  5. restart the proxy
  6. save your config file again
  7. restart your server
  8. go to the backend and update the modules list
  9. check if you can see the modules now
  10. if not reboot the complete server and see that everything gets loaded correctly - check etc/init.d folder if not!
  11. if this still does not help - setup a complete new instance and try it again - it should work!
  12. If you are a newbee try the setup via a script:
  13. i,ho the better one is here: follow it step by step - very easy to do!
  14. Apply all your config file settings again - custom paths
  15. restart the Odoo server
  16. update Modules in the backend
  17. Check if everything is there
  18. It should work! Enjoy Odoo!

With kind regards,
Mit freundlichen Grüßen,
Con un cordial saludo,
с сердечным приветом,


CEO/General Manager LisAndi Co., Ltd.


LisAndi Co. Ltd., Phuket, Thailand (
15/21 M.2 Viset Road, Rawai, Muang, Phuket, Thailand 83130

Mobile: +66 (0)81 606 3378
VoIP:   +49 (0)711 50 88788 50
Fax:     +49 (0)711 50 88788 50
Skype:          lisandi
Facebook:     andibecker
Google Talk/Facetime/eMail:


On Tue, Jun 21, 2016 at 10:16 PM, Ronald Wopereis <> wrote:
did you reboot?

thx, R

2016-06-21 8:32 GMT+02:00 Administracio <>:

Black magic Odoo..., xDDD

Today it works and I didn’t touch anything 

And the password don’t worry is a local ip, testing machine ;)

Thank you so much anyway

Laura Muñoz
Departament de Disseny
SYC Cylinders Europe, SA
Huelva, 1
08940 Cornellà de Llobregat

T 93 336 36 17
F 93 335 81 22

El 20 jun 2016, a las 15:27, Khaled Hamed <> escribió:

seems okey and no special characters.

I add new addon paths for every install with no whitespaces and work fine for me.

New folder for each module as well.

Can you provide the log of the last case since restart (no icons and backend white).

On Mon, Jun 20, 2016 at 2:11 PM, Administracio <> wrote:

cat -ve openerp-server.conf 
; This is the password that allows database operations:$
admin_passwd = superadminpassword$
db_host = False$
db_port = False$
db_user = odoo$
db_password = False$
addons_path = /usr/lib/python2.7/dist-packages/openerp/addons,/usr/lib/python2.7/dist-packages/openerp/custom-addons$
logfile = /var/log/odoo/odoo-server.logroot@alex-HVM-domU:/etc/odoo# 

Laura Muñoz
Departament de Disseny
SYC Cylinders Europe, SA
Huelva, 1
08940 Cornellà de Llobregat

T 93 336 36 17
F 93 335 81 22

El 20 jun 2016, a las 13:42, Khaled Hamed <> escribió:

cat -ve

Post to:

Best regards...

Khaled Hamed Mostafa

Post to:

Post to:

Post to: