Community mailing list archives

community@mail.odoo.com

Re: lots and lots of mail error messages: Routing: posting a message without model should be with a parent_id (private mesage).

by
Skillteam, Houssine BAKKALI
- 05/31/2016 09:15:31
one of the root cause could be that people send mail on your mailhandler@afbs.ch address or the these email address get some spam.

So without mailer id odoo doesn't know to where to redirect the received mail

2016-05-31 14:58 GMT+02:00 Graeme Gellatly <gdgellatly@gmail.com>:

The error is basically saying. You are trying to create a master thread but I don't know where to put it.


On Tue, 31 May 2016 10:18 PM robert rottermann <robert@redcor.ch> wrote:
Hi there,
I get very many error messages sying:
Routing: posting a message without model should be with a parent_id 
(private mesage).

to debug this I
- created a new odoo instance.
- external to odoo I added a mail account
     This process produced a greeting email to the new user
- added an incoming mail server that uses that newly created account.

immediately I get error message written to the new odoo sites log:
     raise ValueError('Routing: posting a message without model should 
be with a parent_id (private mesage).')

If I debug it to the point where the error is thrown, 
(parts/odoo/addons/mail/models/mail_thread.py,) I find the following code:
         if not model and not message_dict.get('parent_id'):
             if assert_model:
                 if not message_dict.get('parent_id'):
                     raise ValueError('Routing: posting a message 
without model should be with a parent_id (private mesage).')
             _warn('posting a message without model should be with a 
parent_id (private mesage), skipping')
             return False

message_dic contains that greeting email:
{   'attachments': [],
     'body': u'Hallo,

Ihr E-Mail-Konto mailhandler@afbs.ch
wurde erfolgreich eingerichtet.

Dies ist eine automatisch generierte
E-Mail, bitte antworten Sie nicht auf
diese Mitteilung.

Ihr Administrator\n\n\n', 'cc': None, 'date': '2016-05-19 09:44:17', 'email_from': u'robert@redcor.ch', 'from': u'robert@redcor.ch', 'message_id': '<bb1acb4eab5cd53f922b2d4ad926c2d2a4f@managemail.redcor.ch>', 'message_type': 'email', 'partner_ids': [], 'subject': u'E-Mail-Konto erfolgreich eingerichtet', 'to': u'mailhandler@xxx.ch'} now my question: what produces that error? what can I do to fix it. I tried to debug what happens, but get drowned in the stack .. thanks robert

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe