Community mailing list archives

community@mail.odoo.com

Re: Should Odoo keep the old API for v10?

by
Cody Kitterman
- 05/09/2016 20:57:06
"In my experiences, migration problemas must be attecked once at a time..."
+1 on that... 

"I prefer very well tested 2.7 code, than not tested 3.4.5 code."
+1

"IMHO Priority should be: New api. Unittest. V3 (Due to we will have uniitest migration can be even automated in some parts)"
+1 +1 +1

Man, Mr. Hernandez is racking up points tonight... 

On a serious note, I've been revamping the installation doc and was thinking over some additional notes concerning Python:

1) Under "Source Install" it directs Windows users to "user the official Python 2.7.9 installer".

Now, am I the only one using 2.7.11? If so, I'll have to make a note for Ubuntu 16.04 users concerning Python2. If not, should I update that reference?

2) Have we been given a time table for the port to Python3?

First and foremost, I'm not rushing anything, but I read somewhere in here that the change is suppose to occur Odoo 11/12. If I can confirm that, I'll add it
 to the doc.

R/S
Cody K.

On Mon, May 9, 2016 at 7:47 PM, Nhomar Hernandez <nhomar@vauxoo.com> wrote:

On Mon, May 9, 2016 at 6:20 PM, zahid jalal <j.zahid@gmail.com> wrote:
+1 @Mohamed Magdy

Last time a migration (Sales and Purchase and anglo_saxon) left us with a code with 100% new flows and 0.5% of tests.

I prefer very well tested 2.7 code, than not tested 3.4.5 code.

IMHO Priority should be:
New api.
Unittest.
V3 (Due to we will have uniitest migration can be even automated in some parts)


--
Nhomar Hernandez
CEO Vauxoo.
Twitter: @nhomar
Odoo Gold Partner
Skype: nhomar00 (Envia mail previo no lo superviso siempre).
Móvil Venezuela:
+58 4144110269
Móvil México:
+52 1 4773933942

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe