Community mailing list archives

community@mail.odoo.com

Re: V9 - wkhtmltopdf installed but not found

by
Arjan Duijs
- 05/06/2016 09:19:22
Hi Cody,
Well the silly thing is (now that i can see the log file again) is that its logging that it can find wkhtmltopf
2016-05-05 22:46:06,204 11997 INFO odoo openerp.addons.report.models.report: Will use the Wkhtmltopdf binary at /usr/local/bin/wkhtmltopdf

so it isnt a path issue my guess

but when printing anything ill get the page in html and the folowing message in odoo (see attachment)
Inline afbeelding 1

I have also tried to set the webkit_path in the configuration file you pointed out earlier but that didnt help.


2016-05-05 20:35 GMT-05:00 Cody Kitterman <ckitterm@gmail.com>:
Mr. Duijs,
      Have you tried adding it to path? I simply installed it in /opt/, created an environment script in /etc/profile.d, and Odoo hasn't had any trouble finding it.
[root@wherever]# vim /etc/profile.d/wkhtmltox_envpath.sh

#!/bin/bash

# Adding wkhtmltopdf and wkhtmltoimage to PATH
PATH=/path/to/wkhtmltox/bin:$PATH
export PATH

# Adding reference to MAN pages, because you never know
MANPATH=/path/to/wkthmltox/share/man:$MANPATH
export MANPATH

~
~
~
~
:wq


[odoo@wherever ~]$ man wkhtmltopdf
Sincerely,
     Cody K.


On Wed, May 4, 2016 at 6:47 PM, Arjan Duijs <arjanduijs@gmail.com> wrote:
It seems that i have a problem as well getting wkhtmltopdf installed properly.

i have it installed on the server (centos7):

josesapelli@wf-50-116-28-65 ~]$ wkhtmltopdf -V
wkhtmltopdf 0.12.2.1 (with patched qt)

the path to the libs is in my WSGI file
sys.path.append('/home/josesapelli/webapps/odoo/lib/python2.7/site-packages')

i read here to add it to the odoo system parameters (done so)

restarted the server... but still not found.

any other tips?

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe