Community mailing list archives

community@mail.odoo.com

Re: 404 when getting CSS for qweb report

by
Paul Catinean
- 05/05/2016 07:31:15
Hello Alexandre,

Did you try setting the report.url system parameter to http://0.0.0.0:8069 ?

On Thu, May 5, 2016 at 2:21 PM, Alexandre Fayolle <alexandre.fayolle@camptocamp.com> wrote:
Hello,

I have troubles with my qweb report. The css cannot be downloaded when
the pdf is generated. Here's an excerpt from the server logs:

2016-05-05 11:15:43,073 24872 INFO ? werkzeug: 127.0.0.1 - -
[05/May/2016 11:15:43] "GET
/web/content/418012-a62486a/report.assets_pdf.0.css HTTP/1.1" 404 -
2016-05-05 11:15:43,081 24873 INFO ? werkzeug: 127.0.0.1 - -
[05/May/2016 11:15:43] "GET
/web/content/418007-02ab18d/report.assets_common.0.css HTTP/1.1" 404 -
2016-05-05 11:15:43,304 24872 INFO ? werkzeug: 127.0.0.1 - -
[05/May/2016 11:15:43] "GET
/web/content/418012-a62486a/report.assets_pdf.0.css HTTP/1.1" 404 -
2016-05-05 11:15:43,304 24873 INFO ? werkzeug: 127.0.0.1 - -
[05/May/2016 11:15:43] "GET
/web/content/418007-02ab18d/report.assets_common.0.css HTTP/1.1" 404 -

This tells me it's not a web.base.url issue. I'm not sure how to proceed
to fix this, and any advice is welcome.

-- 
Alexandre Fayolle
Chef de Projet
Tel : +33 4 58 48 20 30

Camptocamp France SAS
Savoie Technolac, BP 352
73377 Le Bourget du Lac Cedex
http://www.camptocamp.com

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe