Community mailing list archives


Re: migration from 7.0 to 8 using

- 05/04/2016 13:44:21
I have also copied some of the important parts of my migration.log.

On Wed, May 4, 2016 at 10:56 PM, Basanta shrestha <> wrote:

On Wed, May 4, 2016 at 9:47 PM, Harold Tamo <> wrote:

First of all, you only need to run with option --run-migrations=8.0 in order to migrate from 7.0 to 8.0

You need to fix all ERRORS messages (INFO and WARNINGS could be ignored firstly).

After the migration process, try to update all the database (-u option) on V8 source code before going to production. You can also use the OCA's module Database cleanup to clean your database from obsolete data (use this cautiously).

updating the xx_migrated database -u option? could you add a bit on how to do that please ?



2016-05-04 16:33 GMT+01:00 Basanta shrestha <>:
Dear all

I have a project where I need to migrate openerp 7.0 to odoo 8.0. I run debian jessie 64 bit and I want to test the migration on this machine  before doing it on production machine. 

It looks like my openupgrade environment has been setup perfectly because I have openerp 7.0 installed on my virtualbox and when I run 
python --config=xx.conf --database=xx --run-migrations=7.0 

it executes and it makes the xx_migrated database.And I can use the database to get the exact replica. Everything is okay till this poing. 

but when I run the above command with --run-migrations=8.0, it executes the script with few ERRORS, several INFO, DEBUG and some WARNINGS and finally gets exited saying HIT ctrl+c ..... 

The xx_migrated database gets created but when I try to import the database it doesn't work. When I try to import it on my host system with odoo 8.0, I get internal server error. 

Please suggest. 


Post to:


Post to: