Community mailing list archives

Re: [V9.0] timesheet issue

Arjan Duijs
- 04/12/2016 11:40:16
Creating a user is not the problem but more of an extra action.. bit more difficult since NONE of the workers have an email account hehe,

Anyway, the problem is that I (or anyone else who is HR-Manager or direct manager) can not add timesheet for the workers. 
when doing that it results in 0 hours (like in the screenshots attached)

the user alejandro is attached to an odoo user. But i (arjan) am his direct manager in odoo, as well as i have the HR manager rights.

So i would asume, i could enter his timesheets into the system. (i can think of many situations in which a manager should/could do that)

2016-04-12 10:00 GMT-05:00 Dominique KON SUN TACK <>:

On V8, timesheets are attached to employees, but the lines i.e. timesheet lines are attached to user_id, so you can’t have a timesheet on employees who are not users

Probably the same on V9 ?


è You should create users for the factory workers, even if they practically have access




Dominique KON-SUN-TACK


From: Arjan Duijs
Sent: Tuesday, April 12, 2016 9:49 PM
To: Community
Subject: Re: [V9.0] timesheet issue


I have tried this as HR-manager, as well as direct manager of the employee. 

But in all situations same result were as the hours of the employee are not recorded.


Anyone got/know an solution for this?


2016-04-11 15:49 GMT-05:00 Arjan Duijs <>:

Hi All,

I have an issue with timesheets. I am trying to add weekly hours for an employee.

The user i am doing this with is a HR manager.


- first of all, is there a way without attaching an odoo user to an employee to record his/her hours.

Our factory workers do not have odoo accounts, and they pass the hours daily on paper-timesheet.


When i go to employee, select the employee and go to his timesheet.

I click NEW and enter a specific timeperiod.

Add a line of the project/analytic account,  enter the hours the employee has worked on it and press SAVE.


the result is that none of the hours have been registered and all say 0:00 hours.


however when i do the same for my current user, its nicely recorded.


see attachments.




Post to: