Community mailing list archives

community@mail.odoo.com

Re: [9.0c] Python 3 and Odoo 9 / 10 or [2017] Community Edition

by
Esteban Echeverry
- 02/12/2016 06:35:18

Think the only hard dependency rigth now, would be gevent, whose python 3 compatibility is still in release candidate state. I'm also interested in this topic though, even more considering that Ubuntu 16.04 LTS will have Python 3 as default.

On Feb 4, 2016 9:52 PM, "Andreas Becker" <andi@lisandi.com> wrote:
Points which came up in our yesterday meeting and which I would like to ask here!

Tryton is already working with Python Version 3

What about Odoo Community Edition?
Who has experience with converting / rewriting - the core to Python Version 3, perhaps who has already started. 

There was already a Thread about it but it has not been continued for a longer time.

What would it cost (in man/hours) i.e. to rewrite the Odoo Core to Python Version 3? 

What would be the most important modules to be converted or rewritten to Python 3 first, as they are used most often? Is there anywhere a statistic about what modules get used how often or which modele has a lot of stuff depending on, if yes where?

Thanks


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe