Community mailing list archives

community@mail.odoo.com

Website Builder doesn't save changes

by
Felix Villafranca
- 01/05/2016 11:27:46

Hello;

I have my server running without problems and all other odoo applications work perfectly.

2016-01-05 15:45:58,979 1772 INFO ? openerp: OpenERP version 9.0c
2016-01-05 15:45:58,980 1772 INFO ? openerp: addons paths: ['/home/odoo/.local/share/Odoo/addons/9.0', u'/home/odoo/odoo/openerp/addons', u'/home/odoo/odoo/addons']
2016-01-05 15:45:58,980 1772 INFO ? openerp: database: default@default:default
2016-01-05 15:45:59,208 1772 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069

But working with the WebsiteBuilder It’s imposible, when I try to save the changes I always receive the same error in the explorer

Invalid byte sequence for encoding “UTF8“: 0xff

Then I realised that default encoding for python in my system was :”ascii”

UnicodeDecodeError: ‘ascii'' codec can't decode byte 0xff in position 46: invalid start byte

So I changed it to “utf8”. Unfortunately I got the same error but instead of “ascii” showing “utf8”:

UnicodeDecodeError: 'utf8' codec can't decode byte 0xff in position 46: invalid start byte
Logged from file sql_db.py, line 222
2016-01-05 15:43:35,389 1721 ERROR weodoo openerp.http: Exception during JSON request handling.

Then I tried to set encoding default to “'ISO-8859-1’”,  and I get this other error

2016-01-05 15:46:51,229 1772 INFO weodoo openerp.sql_db: bad query: UPDATE "ir_ui_view" SET "arch_db"='ÿþ<',"write_uid"=1,"write_date"=(now() at time zone 'UTC') WHERE id IN (230)
2016-01-05 15:46:51,231 1772 ERROR weodoo openerp.http: Exception during JSON request handling.

As we can see in the “arch_db” appears something wrong ; Doesn’t It?

I’m really confusing.

Any help would be appreciated.

Best regards,
https://github.com/odoo/odoo/issues/10311
¡Un saludo¡

:·)



Félix Villafranca Encinas
 Ingeniero Informático
  Nº Colegiado: 31-0030