Community mailing list archives

community@mail.odoo.com

RE: is proxy_mode still used?

by
Rooms For (Hong Kong) Limited, Yoshi Tashiro
- 11/27/2015 03:00:09

It may depend on the situation, but I think it is better to set “proxy_mode = True” in many cases.

 

I recently had a problem of slides (from website_slide) not finishing “loading” because of mixed content error when SSL was enabled, and that was because `RequestHeader X-Forwarded-Proto “https”` in Apache was not working due to missing “proxy_mode = Trure” in Odoo.

 

Same is true with dbfilter. I think.

 

---

Yoshi Tashiro

 

From: Stephane Wirtel [mailto:stephane@wirtel.be]
Sent: Friday, November 27, 2015 3:57 PM
To: Community <community@mail.odoo.com>
Subject: Re: is proxy_mode still used?

 

Yep, it's used

Without this parameter, the server will display the ip of the proxy and not the real ip.


On 27 nov. 2015, at 8:22 AM, robert rottermann <robert@redcor.ch> wrote:

Hi there,

 

is proxy mode still used in odoo 8 and 9?

 

googling the question brings up only an unclear answer.

 

I am interested because I run an odoo site behind an apache server, that uses 

mod_rewrite.

 

thanks

robert

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe