Community mailing list archives

Re: Import Error Issue on Rel 9 Enterprise editition

Moxylus, Aris Corpuz
- 11/24/2015 16:25:56
Hi Ray,

Have tried that too - importing the csv file with Excel not having been started.

I made sure Excel was not running, then imported the csv file from the Accounting -> Adviser -> Chart of Accounts list view. As soon as the file was chosen (to be imported), the error message appears.

That was from the Enterprise edition of Rel 9. 

Following the same process on the Rel 9 Community version, with Excel running, the same csv file is imported successfully. 

Was asked about the xlrd on our instance and I provided this screenshot.

ubuntu@ip-172-31-26-218:~$ python
Python 2.7.6 (default, Jun 22 2015, 17:58:13)
[GCC 4.8.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import xlrd
>>> print xlrd.__VERSION__
>>> exit
Use exit() or Ctrl-D (i.e. EOF) to exit

Thanks for your feedback, Ray.


Aris Corpuz | Implementation Partner 
moxylus philippines
mobile +63 917.693.8520

On Tue, Nov 24, 2015 at 10:47 AM, Ray Carnes <> wrote:

I have seen this error when the CSV file is open in an Editor that locks the file (such as Excel).


Be sure to close the file if it is open in other programs. 


You can also try Excel import/export– I’ve had that work flawlessly so far.



From: Aris Corpuz []
Sent: Tuesday, November 24, 2015 10:03 AM
To: Community <>
Subject: Import Error Issue on Rel 9 Enterprise editition


Hi Team, 


We are facing an issue when trying to import data into Odoo Enterprise v.9. I used the attached install script to install Odoo. 


When attempting to import .csv files we get the following error: import preview failed due to: unsupported format, or corrupt file: Expected BOF record; found "id,name\r". For CSV files, the issue could be an incorrect encoding"


We get this error even when exporting an import compatible file out of Odoo and immediately attempting to import it without editing it. 


Has anyone experienced this issue before or know of a solution to fix it? We have already tried the different encoding options in the menu, and not having the file open in excel while importing. 


Your help would be very much appreciated. 

Thank you, 



Aris Corpuz | Implementation Partner 
moxylus philippines
mobile +63 917.693.8520 |

Post to:

Post to: