Community mailing list archives

community@mail.odoo.com

Re: [Runbot] Configuration to create only instances of own project addons

by
Christoph
- 11/17/2015 03:52:03
Another question: If I look into the build logs
(runbot/static/build/$BUILD/logs) then sometimes the logs are filled and
sometimes they are empty. Also there exists .lock files. Do you know why
this happens and how I can see the error messages (if I open the
instance then I get an 500er - also the log of odoo with runbot doesn't
contains any further information)?


On 17/11/15 09:33, Christoph Giesel wrote:
> Hi,
> 
> we set up the runbot and the odoo with runbot is running. The runbot can
> fetch the repositories/branches and starts with building (it fails but
> this is another issue which I'm currently fixing).
> 
> So now we just want to create instances for our own project addons. I
> added the odoo repository and also our own repository which depends on
> the odoo repository (added to Extra dependencies).
> 
> First question: Am I right with this configuration? Just adding the odoo
> repository in Extra dependencies and it should work?
> 
> Second question: If I add the odoo repository then it starts with
> building an instance for each pull request and branch but I don't need
> them. Even if I set the mode to "Disabled" and then click "Update" all
> branches and pull requests are shown on the site and they will be put
> into the state "pending". Can I avoid this? Or do I have to fork the
> odoo repository with only the branches 8.0 and 9.0 so that only two
> instances will be created but then I can use them as the dependency?
> 
> Greetings
> Christoph
>