Community mailing list archives

Re: Odoo / Python 3

Skillteam, Houssine BAKKALI
- 11/12/2015 09:31:49
the pills part wasn't for you... but for someone a bit excited in several threads...

Never got this problem on prod env for standard installation... maybe some lib aren't maintened anymore but most of them are... Just keep in mind that most of odoo modules still coded in the old api and that lot of still delcaring model through osv.osv

Odoo SA planned to rewrite all modules to the new api for version 10... they previously aimed 9 and they did not did it... So python 3 is a big step and the release date for 10 is around october 2016. They clearly have to made a choice and for a limited added value job that could not just be in the Entreprise version, I doubt that they will put python 3.x as a priority because even Odoo SA has limited ressources...

I may be wrong or not...

2015-11-12 15:07 GMT+01:00 zahid jalal <>:
Customers are not early adopters, they just need a tool, and Odoo in one of many they use, to run their business. Customers doesn't car about python 2.7 or 3.4 so as far 2.7 is maintained it's ok to stick with it as 2020 is in four years. Their are other big important step before the absolute need of python 3.x

So keep calm and take your pills ;)

Ok, i'll remind you to keep calm by then. When you try to install a module or even the server itself in a prod environment, and some buggy py2.7 lib you depend on is not maintained any more. 
It is stated clearly from python maintainers that "standard library improvements, for example, are only available by default in Python 3.x. "
It's time to move on.


Post to: