Community mailing list archives

Re: connector-magento PHP Version question

Camptocamp SA, Guewen Baconnier - Software Developer, Camptocamp
- 10/19/2015 05:48:43
On Mon, Oct 19, 2015 at 11:43 AM, Peter Alabaster <> wrote:

Hi all, i've been reading through the installation guide and got to this point

My question  is regarding the little 'Important' section:


Please check if you have installed Magento on PHP with a 5.4.x* version. Magento is not compatible with this version and would prevent the API to behave normally. In that case, you must retrograde to PHP 5.3.x or apply the patch provided by Magento (see

Does this mean the connector will not work on a Magento system with PHP 5.5+ installed?
A client has expressed concerns as they are using 5.5, are already looking at using PHP 7, and do not want to downgrade as suggested.

Many thanks
Peter Alabaster

Post to:


This warning concerns Magento 1.7 and it does not says that the connector does not work with PHP 5.4.x but that *Magento* itself does not (been fixed with a patch for Magento 1.7 and in Magento 1.9). We saw many people installing Magento on an unsupported version of PHP and complaining about connector errors, that's why we wrote this notice. In case of doubt, the best source of information is

(this message has been improved on

Guewen Baconnier
Business Solutions Software Developer

Camptocamp SA
PSE A, CH-1015 Lausanne
Phone: +41 21 619 10 39
Office: +41 21 619 10 10