Community mailing list archives

community@mail.odoo.com

error 500 on rendering "data-default-src" images on WSGI install - still not resolved

by
Arjan Duijs
- 10/15/2015 16:11:34
I am still pulling out my hairs on this one. 
Products images and Contact images are displayed like broken image, and the dynamic url generates a 500
it seems so little, but the impact is big and odoo9 isnt workable

I am at a point where i dont have a single clue anymore in what direction i have to search for the problem.

"lessc" was suggested . (installed correctly and paths are working in odoo)
"werkzeug" was suggested (using lates version)
dont know whether it can be the wsgi configuration or the apache conf file.

hopefully someone can point me in the right direction

thanks in advance



2015-10-13 18:12 GMT-05:00 Arjan Duijs <arjanduijs@gmail.com>:
I found on SO a similar case, but that was resolved by upgrading werkzeug
unfortunately that didnt work for me.

I noticed i was running a v10alpha version of odoo, reinstalled the v9.0 and created the whole database anew.
but with the 9.0 i have the same issue.
Noticed that it is for all images that have a "data-default-src"
<img class="oe_topbar_avatar" data-default-src="http://odoo.sapelli.pe/web/static/src/img/user_menu_avatar.png" src="http://odoo.sapelli.pe/web/image?model=res.users&amp;field=image_small&amp;id=1">
where actually the data-default-source is working, while the "src" isnt

below the same error but with the 9.0 install
mod_wsgi (pid=1998): Exception occurred processing WSGI script '/home/josesapelli/webapps/odoo/odoo/openerp-wsgi.py'.
     Traceback (most recent call last):
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/service/wsgi_server.py", line 184, in application
        return application_unproxied(environ, start_response)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/service/wsgi_server.py", line 170, in application_unproxied
         result = handler(environ, start_response)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/http.py", line 1416, in __call__
         return self.dispatch(environ, start_response)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/http.py", line 1390, in __call__
         return self.app(environ, start_wrapped)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/werkzeug/wsgi.py", line 588, in __call__
         return self.app(environ, start_response)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/http.py", line 1586, in dispatch
         return response(environ, start_response)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/werkzeug/wrappers.py", line 1207, in __call__
         start_response(status, headers)
       File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/http.py", line 1389, in start_wrapped
         start_response(status, new_headers)
     ValueError: no space following status code

2015-10-13 9:48 GMT-05:00 Arjan Duijs <arjanduijs@gmail.com>:
Hi All,
The standard admin mugshot image was not displayed well but didnt give it much attention earlier.
But it turns out that none of the contact images are working, and i am unable to change them as well.  
uploading works fine, but saving the contact doesnt change the image

If i call the imag url straight in my browser, it does generate an internal server error as well.


Attached it the isolate part of the error log when an image is requested.

Anyone got some ideas?

thanks