Community mailing list archives

Re: struggling with v9 install

Arjan Duijs
- 10/09/2015 10:09:17
HI Nimesh,
The problem isnt in the node/lessc install. which is installed just fine on the system.

The problem lies in, what jared brought up, is that the user that runs the script cant find the install.

On webfaction we can not install anything in the /usr/bin so instead they have a personal /bin forlder for eacht user  ~/bin

apt-get and sudo dont work either.

I also have tried to put the search path in the start script of apache.
Tried to specify a user for the wsgideamon process in the httpd.conf

none of it helped.


2015-10-08 23:07 GMT-05:00 Nimesh Contractor <>:
Hello Arjan Duijs,

Plese try following steps, must fix your error.

  1. sudo apt-get install curl
  2. curl -sL | sudo bash -
  3. sudo apt-get install -y nodejs
  4. sudo npm install -g npm (to update npm)
  5. sudo npm install -g less less-plugin-clean-css

Nimesh Contractor.

On Thu, Oct 8, 2015 at 7:13 PM, Arjan Duijs <> wrote:
Hi jared,
i have been backing forth messages with webfaction on this matter, they say the script runs under the same user. 

in the errorlog i found the following:
 mod_wsgi (pid=4123): Exception occurred processing WSGI script '/home/josesapelli/webapps/odoo/odoo/'.
 Traceback (most recent call last):
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/service/", line 184, in application
     return application_unproxied(environ, start_response)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/service/", line 170, in application_unproxied
     result = handler(environ, start_response)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/", line 1416, in __call__
     return self.dispatch(environ, start_response)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/", line 1390, in __call__
     return, start_wrapped)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/werkzeug/", line 588, in __call__
     return, start_response)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/", line 1586, in dispatch
     return response(environ, start_response)
  File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/werkzeug/", line 1207, in __call__
     start_response(status, headers)
   File "/home/josesapelli/webapps/odoo/lib/python2.7/site-packages/odoo-9.0-py2.7.egg/openerp/", line 1389, in start_wrapped
     start_response(status, new_headers)
 ValueError: no space following status code not execute command 'lessc'

2015-10-06 19:17 GMT-05:00 <>:
But does Odoo run as that user?
Are you starting Odoo from that shell?


On Oct 6, 2015, at 3:37 PM, Arjan Duijs <> wrote:

Hi Jared,

had tried to create the symlink before.
ln: creating symbolic link `/usr/bin/lessc': Permission denied
(webfaction doesnt allow to write there, instead you have your personal 'bin' located at  ~/bin  i did create the symlink there, so which resolves to that location)

echo $PATH:
[josesapelli@web452 ~]$ echo $PATH

2015-10-06 15:51 GMT-05:00 <>:
ln -s `which lessc` /usr/bin/lessc

If that doesn't work, su into the user and echo $PATH


On Oct 6, 2015, at 9:33 AM, Arjan Duijs <> wrote:

Hi Jared,
[josesapelli@web452 ~]$ lessc -v lessc 2.5.3 (Less Compiler) [JavaScript]

Op 6 okt. 2015 10:39 schreef <>:
The less application you resolved is GNU less (text processor), not lessc (CSS preprocessor).

Check the path of the user you run Odoo as and ensure lessc is somewhere in it. 


On Oct 3, 2015, at 6:38 AM, Arjan Duijs <> wrote:

Hi all,
I am realy struggling with my v9 install and dont seem to get it worrk properly in my webfaction environment.

- installed node + less (added paths and verified if both are executable from the cmd line

[josesapelli@web452 ~]$ less -V
less 436
Copyright (C) 1984-2009 Mark Nudelman

[josesapelli@web452 ~]$ npm -version

created a virtualenv to install odoo

within the virtualenv:

verified if LESS was still working

pip install -r requirements.txt  (gevent wouldnt instll due to wheel errors, after removing gevent it installed all the addons)

python install

created the Database

and browse to odoo:\

But still getting the "Could not execute command 'lessc" and the admin panel is missing quite some styles (does not render propetly)

Event installing the blog addon as some suggested doesnt make a difference.
So somehow odoo still cant get to less, but the cmd line does say otherwise.

Hopefully someone got an idea.



Post to:

Post to:

Post to:

Post to:

Post to:

Post to:

Nimesh Contractor
Mob: 9824480374
Skype : nimesh.contractor

Post to: