Community mailing list archives

Invalid CSRF Token

Eric Caudal
- 10/04/2015 04:34:20
I have pulled today all code from v9 and enterprise
I can run v9 community properly  (create db and access it)  but I cannot create db in v9 Enterprise.
When I click on create new db, I receive the following message in the browser:
Bad Request
Invalid CSRF Token

I get the following error in log-web:
2015-10-04 05:54:30,375 22963 ERROR ? werkzeug: Error on request:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/werkzeug/", line 177, in run_wsgi
  File "/usr/lib/python2.7/dist-packages/werkzeug/", line 165, in execute
    application_iter = app(environ, start_response)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/service/", line 245, in app
    return, s)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/service/", line 184, in application
    return application_unproxied(environ, start_response)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/service/", line 170, in application_unproxied
    result = handler(environ, start_response)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 1416, in __call__
    return self.dispatch(environ, start_response)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 1390, in __call__
    return, start_wrapped)
  File "/usr/lib/python2.7/dist-packages/werkzeug/", line 588, in __call__
    return, start_response)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 1583, in dispatch
    result = _dispatch_nodb()
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 1556, in _dispatch_nodb
    result = request.dispatch()
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 768, in dispatch
    r = self._call_function(**self.params)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 316, in _call_function
    return self.endpoint(*args, **kwargs)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 887, in __call__
    return self.method(*args, **kw)
  File "/home/eric/odoo/CVS/9.0/odoo/openerp/", line 465, in response_wrap
    response = f(*args, **kw)
TypeError: create() takes exactly 5 arguments (1 given)

difference in my conf files between v9 and v9 enterprise is:
eric@XPS-15Z:~/odoo/CVS/9.0$ diff ./openerp-server_enterprise.conf openerp-server.conf
< addons_path = /home/eric/odoo/CVS/9.0/enterprise,/home/eric/odoo/CVS/9.0/odoo/openerp/addons,/home/eric/odoo/CVS/9.0/odoo/addons
> addons_path = /home/eric/odoo/CVS/9.0/odoo/openerp/addons,/home/eric/odoo/CVS/9.0/odoo/addons
< dbfilter = ^e9.*$
> dbfilter = ^v9.*$
< xmlrpc_port = 9939
> xmlrpc_port = 9999
< xmlrpcs_port = 9930
> xmlrpcs_port = 9990

I tried in ff and chrome (normal and private mode)
I tried to update web module from an community created db: I get to first login screen then same error.

Any pointer to solve this would be appreciated.

Eric  Caudal (from my mobile)