Community mailing list archives

community@mail.odoo.com

Re: struggling with v9 install

by
Borut
- 10/03/2015 11:31:57
I got the same screen after clean install of Odoo 9 Community from GitHub

I had to install nodejs + npm + less on Ubuntu Server 15.04 with:

sudo apt-get install nodejs
sudo apt-get install npm
sudo ln -s /usr/bin/nodejs /usr/bin/node
sudo npm install -g less less-plugin-clean-css

It worked after this (and couple of 'Force Reload This Page' in Chrome).

I also installed Blog app on a different db but that didn't solve the problems in that db. I didn't need to install Blog app in my db that is working. Maybe the first Blog app install solved something but it is not needed anymore. I believe the 3rd sudo line (sudo ln -s....) is the one that fixed the nodejs install for me. This line is also missing on the linked StackOverflow post.

Kind regards,
Borut


On Sat, Oct 3, 2015 at 5:17 PM, Arjan Duijs <arjanduijs@gmail.com> wrote:
i Jordi,
I did find the github issues, but that isnt my problem.

like i mentioned, installing the blog module (or any other other less using module) doesnt solve the problem.

The whole admin side of odoo is malformed as well.
So somehow odoo can not find/execute lessc still... even though the order of installing the dependencies was right.

Inline afbeelding 2

2015-10-03 8:48 GMT-05:00 Jordi Ballester Alomar <jordi.ballester@eficent.com>:

Arjan it happened to me as well. It has been logged as an issue in Github. You must install module 'website_blog' from command line. This will resolve it as a workaround.

El dia 03/10/2015 15:38, "Arjan Duijs" <arjanduijs@gmail.com> va escriure:
Hi all,
I am realy struggling with my v9 install and dont seem to get it worrk properly in my webfaction environment.

- installed node + less (added paths and verified if both are executable from the cmd line

[josesapelli@web452 ~]$ less -V
less 436
Copyright (C) 1984-2009 Mark Nudelman

[josesapelli@web452 ~]$ npm -version
2.11.3

created a virtualenv to install odoo

within the virtualenv:

verified if LESS was still working


pip install -r requirements.txt  (gevent wouldnt instll due to wheel errors, after removing gevent it installed all the addons)

python setup.py install

created the Database

and browse to odoo:\

But still getting the "Could not execute command 'lessc" and the admin panel is missing quite some styles (does not render propetly)

Event installing the blog addon as some suggested doesnt make a difference.
So somehow odoo still cant get to less, but the cmd line does say otherwise.

Hopefully someone got an idea.

thanks!
arjan




_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe