Community mailing list archives

Re: error in reportlab

Ronald Wopereis
- 09/26/2015 05:37:52
​restarting server does not solve the problem.
what else can i try?
any suggestion is much appreciated
best regards, Ron​

2015-09-25 14:27 GMT+02:00 Houssine BAKKALI <>:
I recently got this error on some standard accounting report that was working well until the error arised and restarting the server solved the problem.

2015-09-25 0:08 GMT+02:00 Ronald Wopereis <>:
hi all,

i get following error in reportlab when printing a barcode label :

  File "/usr/share/pyshared/reportlab/graphics/", line 221, in _setFont
    raise RenderPMError, "Can't setFont(%s) missing the T1 files?\nOriginally %s: %s" % (fontName,s1,s2)
RenderPMError: Can't setFont(Times-Roman) missing the T1 files?
Originally <type 'exceptions.TypeError'>: makeT1Font() argument 2 must be string, not None

creating and filling the reportlab/fonts directory i tried, but then the odoo server hangs on the report, and won't come back unless i delete the fonts subdir and reboot the server.

to reproduce, i only need to do this:

and it gives me a 500 error.
in the odoo-error.log appears the very same error.

any suggestions would be very much welcome.
thx, Ron

Post to:

Post to: