Community mailing list archives

community@mail.odoo.com

Re: Can't restart openerp server

by
jeanyves.randria
- 08/14/2015 03:12:22

Hi, Stop postgresql server, then restart your server.  After restart server, start odoo.

Regards,

JYRA.

On Aug 14, 2015 8:18 AM, "shubhada@supersimplesoft.com" <shubhada@supersimplesoft.com> wrote:
Hello Peter,

I think you should check for the folders permission in odoo/openerp folder.

And then put on the technical data for the admin user and update modules.


-- 
Thanks & Regards,
Shubhada 
www.SuperSimpleSoft.com | +91 942 396 5356



On Friday 14 August 2015 07:52 AM, Jay Vora (SerpentCS) wrote:
<blockquote cite="mid:wrnkcwx7o32rlg2gna3kgssb.1439518771606@email.android.com" type="cite">Peter,

Either you miss addons, or the files have bad permissions.

As a safecheck, you can see db schema whether the table is still there or not.

At the end, run your server with -u all -d dbname.

Thanks,
Regards,
Jay Vora.
Serpent Consulting Services Pvt Ltd.
M : 091-9879354457


-------- Original Message --------
From:Chico Venancio <chicocvenancio@gmail.com>
Sent:Fri, 14 Aug 2015 00:56:40 +0530
To:Community <community@mail.odoo.com>
Subject:Re: Can't restart openerp server

Is the problem really the database? Can you try to start from fresh code, perhaps from git or nightly.

Chico Venancio
CEO VM Tech

Em 13/08/2015 16:12, "Kristian Koci" <kristian.koci@gmail.com> escreveu:
I think there is something with your invoice template, maybe some tag, calling for a method that db couldn't find at restart.

Don't you have a backup?

Any other database other than the one you were modifying?


On Thu, Aug 13, 2015 at 2:33 PM, Peter Aronson (Biluu) <odoo@biluu.mx> wrote:
I had activated accounting and warehouse and I installed auto-backup (very unfortunately not working). I also made changes to the invoice template using qweb.


On Aug 13, 2015, at 1:52 PM, Kristian Koci <kristian.koci@gmail.com> wrote:

Did you modify any module before restarting?

On Thu, Aug 13, 2015 at 2:13 PM, Peter <odoo@biluu.mx> wrote:

I think my openerp database is corrupt because I'm unable to get the server to restart. I am getting:


2015-08-13 14:14:11,778 25362 ERROR username openerp.sql_db: Programming error: relation "ir_module_module" does not exist
LINE 1: SELECT 1 FROM ir_module_module WHERE name='base' AND latest_...
                      ^
, in query SELECT 1 FROM ir_module_module WHERE name=%s AND latest_version=%s
2015-08-13 14:14:11,778 25362 WARNING username openerp.addons.base.ir.ir_cron: Tried to poll an undefined table on database username.

Does anyone know how I can fix this and get the server to start again?

I didn't do any updates…

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe




--
Kristian Koci
Linux User #582221

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe