Community mailing list archives

how do I start odoo from a.r.odoo was:Re: anybox.recipe.odoo: still fighting to get it running

redCOR AG, robert rottermann
- 07/25/2015 17:01:11
hi there

I am still not able to run odoo generated by  a.r.odoo.

there is a script bin/start_openerp. But when I run it, it does not attempt to use port 8069.
This I found out by running a "normally" installed odoo and running bin/start_openerp simultaneously.

This should produce an error, that port 8069 is allready in use.
But it does not.

However, when I run parts/odoo/ which is also generated by buildout, such an error is raised.

I am using the following cfg files:
extends = base_recipe.cfg

version = git odoo 8.0
eggs = pyPdf

reportlab = 2.7

parts = openerp
find-links =
versions = versions
extensions = gp.vcsdevelop
vcs-extend-develop =
vcs-update = True

recipe = anybox.recipe.openerp[bzr]:server
options.xmlrpc = False
options.xmlrpcs = False
options.netrpc = False
eggs = nose
openerp_scripts = nosetests=nosetests command-line-options=-d

recipe = anybox.recipe.openerp:webclient
version = 6.1-1

recipe = anybox.recipe.openerp:gtkclient
version = nightly 6.1 latest

reportlab = 2.7

Is there anything missing in these config files?

any help is greatly appreciated


recipe-odoo-80.cfg -> buildout.cfg

and did run bin/buildout.

then I did run the created script:

here is the output:

robert@mozart:~/projects/urgestein/urgestein$ bin/start_openerp
2015-07-24 10:31:32,963 30989 INFO ? openerp: OpenERP version 8.0
2015-07-24 10:31:32,964 30989 INFO ? openerp: addons paths: 
2015-07-24 10:31:32,964 30989 INFO ? openerp: database hostname: localhost
2015-07-24 10:31:32,964 30989 INFO ? openerp: database port: 5432
2015-07-24 10:31:32,964 30989 INFO ? openerp: database user: robert
<blockquote cite="" type="cite">
It is good, you have your own odoo project, modify the buildout config file to add add ons, this file represent your odoo customer project 
now what?
I am lost what to do next.
how can I access the web interface?
open a browser, start_openerp run the odoo server 
I tried to add the webclient to the buildout process but this produced 
an error saying odoo-8 does not need it.
before OpenERP V6.1, the web client was not with the server, but since 6.1 they are no need to add a new part for have the web server 
thanks for your help


Post to:

Jean-Sébastien SUZANNE

Post to: