Community mailing list archives

community@mail.odoo.com

Re: anybox.recipe.odoo: still fighting to get it running

by
redCOR AG, robert rottermann
- 07/24/2015 10:01:52
merci bien Jean-Sébastien
On 24.07.2015 14:17, Jean-Sébastien Suzanne wrote:
<blockquote cite="mid:CAJg4io3o5qSVRGeMzWma68NFAXtDRzwGSXX4OCS0sAVa5zO4wg@mail.gmail.com" type="cite">


2015-07-24 12:37 GMT+02:00 robert <robert@redcor.ch>:
Hi there,

I am still trying to understand how to use anybox.recipe.odoo.

What I did so far, is created a virtual env evironment,
then i did copy the two config files:
recipe-odoo-80.cfg -> buildout.cfg
base_recipe.cfg

and did run bin/buildout.

then I did run the created script:
bin/start_openerp

here is the output:

robert@mozart:~/projects/urgestein/urgestein$ bin/start_openerp
2015-07-24 10:31:32,963 30989 INFO ? openerp: OpenERP version 8.0
2015-07-24 10:31:32,964 30989 INFO ? openerp: addons paths: 
['/home/robert/.local/share/Odoo/addons/8.0', 
u'/home/robert/projects/urgestein/urgestein/parts/odoo/openerp/addons', 
u'/home/robert/projects/urgestein/urgestein/parts/odoo/addons']
2015-07-24 10:31:32,964 30989 INFO ? openerp: database hostname: localhost
2015-07-24 10:31:32,964 30989 INFO ? openerp: database port: 5432
2015-07-24 10:31:32,964 30989 INFO ? openerp: database user: robert
It is good, you have your own odoo project, modify the buildout config file to add add ons, this file represent your odoo customer project 
now what?
I am lost what to do next.
how can I access the web interface?
open a browser, start_openerp run the odoo server
this seems to be my problem..
I start my browser, wnt to go to localhost:8069 and an "unable to connect" message is presented.

by the way, there is no difference, whether postgresql is started or not ..

any more info, is there somethin I can test "from the commandline"

thanks a lot
robert

<blockquote cite="mid:CAJg4io3o5qSVRGeMzWma68NFAXtDRzwGSXX4OCS0sAVa5zO4wg@mail.gmail.com" type="cite">
I tried to add the webclient to the buildout process but this produced 
an error saying odoo-8 does not need it.
before OpenERP V6.1, the web client was not with the server, but since 6.1 they are no need to add a new part for have the web server 
thanks for your help

robert



_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe




--
Jean-Sébastien SUZANNE
jssuzanne@anybox.fr

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe