Community mailing list archives

community@mail.odoo.com

Re: Missing footer with Report-rtl module

by
XPANSA, Oleg Kuryan - Chief Technical Officer, Xpansa Group
- 07/15/2015 14:34:31
Mohamed,

If setting report.url same as web.base.url , and if Odoo is behind proxy - footer will disappear from report. I think problem is on wkhtmltopdf side. 

Regarding settings I described above, they work fine everywhere, except systems that are using db_filter. In case db_filter is set, reports that have barcodes printed inside them are logging user out after printing. But that is different story.

///

Best Regards,
Oleg Kuryan


Technical Director, XPANSA Group | ERP, BI, E-commerce, Data Mining and DMS consulting
Xpansa has developed first full Odoo Android App called mERP. Download at https://play.google.com/merp
/// site  : xpansa.com
/// mail  : oleg.kuryan@xpansa.com
/// phone : +375293358638
/// skype : kuryan.
oleg

On Wed, Jul 15, 2015 at 9:28 PM, Mohamed M. Hagag <mohamedhagag1981@gmail.com> wrote:

Thanks Oleg,


this parameter seems to fix the wired behavior of wkhtml, but it should be same as the base.url even behind a proxy otherwise you may get odoo crashed or unresponsive .


Regards,


On 07/15/2015 06:09 PM, Oleg Kuryan wrote:
<blockquote cite="mid:CAJeyqWLhHiAKq+h_zKEHLXJ9k03wprmXpXQRmMqD03fN1TJWjw@mail.gmail.com" type="cite">
Hi Pradeep,

You need to check the following:
1) Check that version of wkhtmltopdf is 0.12.1 

~# wkhtmltopdf --version

wkhtmltopdf 0.12.1 (with patched qt)

Below are simple commands to install proper version on Ubuntu 14.04 LTS:

sudo apt-get remove wkhtmltopdf 

cd /usr/local/src/ 

sudo wget http://garr.dl.sourceforge.net/project/wkhtmltopdf/archive/0.12.1/wkhtmltox-0.12.1_linux-trusty-amd64.deb 

sudo apt-get install libfontenc1 libxfont1 x11-common xfonts-75dpi xfonts-base xfonts-encodings xfonts-utils 

sudo dpkg -i wkhtmltox-0.12.1_linux-trusty-amd64.deb 

sudo cp /usr/local/bin/wkhtmltopdf /usr/bin 

sudo cp /usr/local/bin/wkhtmltoimage /usr/bin

2) If you are running apache/nginx as proxy for Odoo 8 Go to "Settings -> Technical -> Paramers -> System Parameters" and create new paraneter "report.url" with value "http://localhost:8069" or whatever port you have. See screen below




///

Best Regards,
Oleg Kuryan


Technical Director, XPANSA Group | ERP, BI, E-commerce, Data Mining and DMS consulting
Xpansa has developed first full Odoo Android App called mERP. Download at https://play.google.com/merp
/// site  : xpansa.com
/// mail  : oleg.kuryan@xpansa.com
/// phone : +375293358638
/// skype : kuryan.
oleg

On Wed, Jul 15, 2015 at 6:36 PM, Humberto Arocha <hbto@vauxoo.com> wrote:

Hi, there was a bug in odoo a long time ago, and was worked around.

Your Linux needs some settings so that limits for files open is not reached, check wkhtmltopdf issues in github a workaround is provided,

In prior threads in this mailing list that same solution is provides.

Best regards

On Jul 15, 2015 10:09 AM, "Mohamed M. Hagag" <mohamedhagag1981@gmail.com> wrote:

It's not the odoo-rtl module,


It's the wkhtml which is behaving randomly with headers and footers.




On 07/15/2015 03:58 PM, Pradeep Singh wrote:
<blockquote cite="mid:CAPn578rL17k_TSJrWQM8EQgBKr9a2pnXkwSimBjGFd0M8dDgSA@mail.gmail.com" type="cite">
Hi!
 Something is wrong with the module. May be wrongly called the footer.

On Tue, Jul 14, 2015 at 1:14 AM, Mustafa J. Kadhem Al-Azaam <safi2266@gmail.com> wrote:

I am using all these modules

https://www.odoo.com/apps/modules?author=Mohammed Barsi

to flip odoo to rtl to suite Arabic language direction.

I have an issue with arabic qweb report which is the footer part from the report are always missing, but when uninstall report_rtl the footer shows properly.

So

- I wondering is there someone doesn't has this issue like me

- Do anyone has an suggestion to solve this

Regards

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe




--
With Regards!
Pradeep Singh
+91-9568728648

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe