Community mailing list archives

community@mail.odoo.com

Re: How to setup domain for Odoo server?

by
Blanco Martin EIRL
- 06/19/2015 17:57:41
Take a look here, hope it helps:

This is how you should configure apache

<VirtualHost *:80>
    ServerName abc.domainname.com
    ServerAlias zyz.otherdomainyours.com
    ProxyPass  / http://localhost:8069/
    # you can also use an already directed to your server domains
    Header add X-ODOO_DBFILTER "yourdatabase"
    RequestHeader add X-ODOO_DBFILTER "yourdatabase"
</VirtualHost>

Then restart apache.

You will need to install this module in your odoo instance, but the way to install it is using odoo.conf

dbfilter_from_header (OCA).

server_wide_modules=web,dbfilter_from_header # this line should be in the odoo.conf file. The server_wide_modules usually already exists in your server, but just with =web. Add dbfilter_from_header to this line.

This worked like a charm for me. In other customers' instances, I made exactly the same thing but with nginx instead of apache (works faster).






Quedo atento a sus comentarios. Saludos:



Ing. Daniel Blanco
Director
Blanco Martín & Asociados
Móvil: +56 9 73880409 / +54 9 351 228-0893
Skype: hdanielb
Twitter: hdanielb

Chile: 
Blanco Martín EIRL
Apoquindo 6410 Of 212
+56 2 2840 0990 / +56 2 2979 0208
Las Condes - Región Metropolitana

Argentina:
BMyA S.A.
Nicasio 6970. Córdoba
+54 351 5694621 / +54 351 5691933
Argüello - Córdoba




2015-06-19 16:40 GMT-03:00 Rudi Grosberg <rudi.grosberg@gmail.com>:
Hi Amit,

I tried doing this adding IP to redirect the subdomain to my Odoo IP but the problem i am facing is if i enter abc.domainname.com in browser it takes me to Odoo IP but doesnt stays on abc.domainname.com 

Can anyone suggest how to do this that it stays on abc.domainname.com instead of showing the IP.

On Fri, Jun 19, 2015 at 4:15 PM, Amit Parik <amitparikit1987@gmail.com> wrote:
Hi Togar,

What I suggest, You can setup the apache on sever and redirect the port 8069 to port 80.
And set the DNS on your website(this is you already did I guess).

After this whenever you open the mydomain.com odoo services has been called and open the odoo .
Hope this can help.

On Fri, Jun 19, 2015 at 3:26 PM, Togar Hutabarat <to.garnet@gmail.com> wrote:

Dear Community,

I remember there is (was) an article talking about setting up domain for Odoo without port after the domain URL. But too bad I can't find it now. Currently my Odoo server is available on mydomain.com:8069. What do I need to do to make it accessible on subdomain without port (mysubdomain.mydomain.com) ?

Best regards,
Togar Parnaehan Hutabarat

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe




--
---------
Thanks & regards,
Amit Parik

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe