Community mailing list archives

Re: POS on Odoo 8

Alejandro Perez Cosio
- 03/02/2015 13:07:44
Hello Sylvain,

I also think that could work with the posbox, but actually I'm running from a normal linux PC with virtualenv for python dependencies, if I use sudo in a virtualenv, I get dependencies errors..

On 02/03/15 13:22, Sylvain LE GAL wrote:
<blockquote cite="" type="cite">

I had the same problem with my posbox on a raspberry. I temporaly solved the problem running the process as sudoer on my raspberry.


Sylvain LE GAL
Service informatique
GRAP - Groupement Régional Alimentaire de Proximité

3 Grande rue des Feuillants, 69001 Lyon
Bureau :
Astreinte :
GRAP sur le Web : Site Web | Facebook | Twitter
GRAP - service Informatique sur le Web : Twitter

2015-03-02 16:09 GMT+01:00 Alejandro Perez <>:

Dear all

I got all the recommended hardware to work with the Odoo 8 POS: EPSON TM-20II, Honeywell eclipse barcode-scanner, cashier box linked to the printer. Everything is working fine if I use the barcode-scanner separately or if print a receipt from a PDF file, but I can't make it print from the POS module pushing the "Receipt" button.

Also, I'm getting this error each 5 seconds after installing the hw_escpos (not sure where I should give additional permissions):

2015-03-02 13:19:06,041 7815 INFO ? openerp.addons.hw_escpos.controllers.main: connected : Connected to Epson TM-T20II
2015-03-02 13:19:06,042 7815 INFO ? openerp.addons.hw_escpos.controllers.main: error : [Errno 13] Access denied (insufficient permissions)
2015-03-02 13:19:06,042 7815 ERROR ? openerp.addons.hw_escpos.controllers.main: ESC/POS Error: [Errno 13] Access denied (insufficient permissions)

I tried with usbusers group described at here with no luck.

So, my questions would be:
- where should I add additional permissions to avoid the error message?
- which modules should I install to print my receipt from the POS application?
- I'll get soon some raspberry-py model B, each of them will be linked to its own printer and a scanner, which graphic interface would you recommend to install on it?

I'm working with virtualenv for python dependencies.

Thank you and best regards to all!


Post to:

Post to: