Community mailing list archives

community@mail.odoo.com

Re: Problems with Running odoo 8.0 under centos 7.0

by
Erastus
- 01/09/2015 02:58:56
Zengjian,


I re installed centos 4 times and checked all packages.  I nthen checked 
post gress and all related stuff.
Centos 7 is 100%.

I reinstalled odoo seve3ral times and found the same problem.
I was then told by some person that all addons is not yet converted from 
odoo 7 to odoo 8.

I personally recon it is an odoo module problem and that must be sorted.

I will tell you which modules I avoided to and then you can use them on  
odoo 8 & centos 7






On 2015-01-09 09:47, shiqian@agrite.com.cn wrote:
> Hello Rocco and Erastus,
> 
> Thank you for your response. In fact, my addons path
> is /opt/odoo/odoo/addons. It's same with what I used in the
> configuration file, but I still got the errors. Is there any other
> mistakes you think I may have?
> 
> Zengjian
> 
> -------------------------
> 
> shiqian@agrite.com.cn
> 
>>  
>> 
>> FROM: 游增建
>> DATE: 2015-01-09 10:27
>> TO: Community
>> SUBJECT: Problems with Running odoo 8.0 under centos 7.0
>> 
>> Hello Community,
>> 
>> I was trying to run odoo 8.0 by using the source code under centos
>> 7.0. However, some errors were returned.
>> 
>> The path of odoo is /opt/odoo/odoo
>> The command line is ./odoo.py --config=/etc/odoo-server.conf
>> 
>> Configuration file detail is shown as below:
>> 
>> [options]
>> ; This is the password that allows database operations:
>> ; admin_passwd = admin
>> db_host = False
>> db_port = False
>> db_user = odoo
>> db_password = odoo
>> addons_path = /opt/odoo/odoo/addons
>> 
>> The errors I got is shown as below:
>> 
>> 2015-01-09 01:06:56,635 32094 INFO ? openerp: OpenERP version 8.0
>> 2015-01-09 01:06:56,635 32094 INFO ? openerp: addons paths:
>> ['/opt/odoo/.local/share/Odoo/addons/8.0', u'/opt/odoo/odoo/addons',
>> 
>> '/opt/odoo/odoo/openerp/addons']
>> 2015-01-09 01:06:56,635 32094 INFO ? openerp: database hostname:
>> localhost
>> 2015-01-09 01:06:56,635 32094 INFO ? openerp: database port: 5432
>> 2015-01-09 01:06:56,635 32094 INFO ? openerp: database user: odoo
>> 2015-01-09 01:06:56,810 32094 CRITICAL ? openerp.modules.module:
>> Couldn't load module web
>> 2015-01-09 01:06:56,811 32094 CRITICAL ? openerp.modules.module:
>> could
>> not open display
>> 2015-01-09 01:06:56,811 32094 ERROR ? openerp.service.server: Failed
>> to
>> load server-wide module `web`.
>> The `web` module is provided by the addons found in the
>> `openerp-web`
>> project.
>> Maybe you forgot to add those addons in your addons_path
>> configuration.
>> Traceback (most recent call last):
>>    File "/opt/odoo/odoo/openerp/service/server.py", line 842, in
>> load_server_wide_modules
>>      openerp.modules.module.load_openerp_module(m)
>>    File "/opt/odoo/odoo/openerp/modules/module.py", line 313, in
>> load_openerp_module
>>      __import__('openerp.addons.' + module_name)
>>    File "/opt/odoo/odoo/openerp/modules/module.py", line 77, in
>> load_module
>>      mod = imp.load_module('openerp.addons.' + module_part, f,
>> path, descr)
>>    File "/opt/odoo/odoo/addons/web/__init__.py", line 8, in
>> 
>>      import controllers
>>    File "/opt/odoo/odoo/addons/web/controllers/__init__.py", line
>> 1, in
>> 
>>      from . import main
>>    File "/opt/odoo/odoo/addons/web/controllers/main.py", line 34,
>> in
>> 
>>      from openerp.addons.base.ir.ir_qweb import AssetsBundle,
>> QWebTemplateNotFound
>>    File "/opt/odoo/odoo/openerp/modules/module.py", line 77, in
>> load_module
>>      mod = imp.load_module('openerp.addons.' + module_part, f,
>> path, descr)
>>    File "/opt/odoo/odoo/openerp/addons/base/__init__.py", line 25,
>> in
>> 
>>      import res
>>    File "/opt/odoo/odoo/openerp/addons/base/res/__init__.py", line
>> 24,
>> in 
>>      import res_partner
>>    File "/opt/odoo/odoo/openerp/addons/base/res/res_partner.py",
>> line
>> 35, in 
>>      from gtk._gtk import STOCK_ABOUT
>>    File
>> "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py",
>> line 64, in 
>>      _init()
>>    File
>> "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py",
>> line 52, in _init
>>      _gtk.init_check()
>> RuntimeError: could not open display
>> 
>> Could anyone help me to solve this problem? I appreciate your help.
>> 
>> Thank you,
>> Zengjian
>> 
>> _______________________________________________
>> Mailing-List: https://www.odoo.com/groups/community-59
>> Post to: mailto:community@mail.odoo.com
>> Unsubscribe: https://www.odoo.com/groups?unsubscribe
> 
> _______________________________________________
>  Mailing-List: https://www.odoo.com/groups/community-59
>  Post to: mailto:community@mail.odoo.com
>  Unsubscribe: https://www.odoo.com/groups?unsubscribe