Odoo Aide

0

0
1 Réponse
0
Avatar

Ermin Trevisan Suisse

--Ermin Trevisan--
16464
| 8 7 10
Walchwil, Suisse
--Ermin Trevisan--


Ermin Trevisan Suisse
02/04/2017 03:42

What you describe is not true for an Odoo standard set up. If your system behaves like that, you have misconfigured it.

Please check your settings concerning:

- Tax rounding method (globally or per line), see "Accountings/Settings/Chart of Account/Configure your company data"

- decimal precision of your pricelists

- decimal precision of your currencies

- decimal accuracy "Settings/Technical/Database structure/Decimal Accuracy"


18 Commentaires
Borja Espagne
04/04/2017 03:08

Where can i check decimal precision of pricelists and currencies?

twanda AG, Ermin Trevisan Suisse
04/04/2017 03:58

You have to activate the developer mode to see the options.

Borja Espagne
04/04/2017 06:39

I found these options. I changed tax rounding method to globally, but its ignoring me.

If i change precision to 00,001 odoo shows prices with 3 decimals.

Why its ignoring me?

twanda AG, Ermin Trevisan Suisse
04/04/2017 07:53

There is another setting, which I have amended to my answer, decimal accuracy, check this also. However, somebody obviously did change the settings in your system because out of the box Odoo works properly with 2 digits and proper rounding.

twanda AG, Ermin Trevisan Suisse
04/04/2017 07:55

Or did you install a module such as "Swedish rounding"?

Borja Espagne
04/04/2017 08:52

I didnt install an other country module. This is spanish mod. I have developer options actived but can't find decimal accuracy. Only rounding factor.

Thanks

twanda AG, Ermin Trevisan Suisse
04/04/2017 09:00

"Swedish rounding" is not a country module, that's a special rounding (5 cents rounding).

twanda AG, Ermin Trevisan Suisse
04/04/2017 09:03

See my amended answer for the decimal accuracy.

Borja Espagne
05/04/2017 03:02

Decimal accuracy is set to 2 digits for product price.

twanda AG, Ermin Trevisan Suisse
05/04/2017 03:06

Then I do not have any more ideas than just completely updating your Odoo instance. Either you or somebody else did manipulate the original settings either manually or be installing a module.

Borja Espagne
05/04/2017 03:25

Where can i check if sweedish rounding is active??? Thanks

twanda AG, Ermin Trevisan Suisse
05/04/2017 03:37

You must have installed a module like https://www.odoo.com/apps/modules/8.0/smile_decimal_precision/ in order to have swedish rounding, or have a rounding factor of 0.1 in your currency definition.

Borja Espagne
05/04/2017 03:53

i have not installes any modules for change decimal precision. Also, rounding factor is set to 0.01 and rounding for taxes is set to globally and not "per line". The option is set and saved. I reboot the server and didnt change anything. Its ignoring me.

Its Odoo9.

twanda AG, Ermin Trevisan Suisse
05/04/2017 04:29

You have messed up your instance, don't ask me how and why. It is properly working for thousands of installations. Look at your logs if there's anything suspicious, else try to update your instance and see if it works, otherwise I would recommend you a new clean install.

Borja Espagne
05/04/2017 06:07

its a new install, its tunning for only a month aprox. I dont understand. Its installed over debian 8.

Borja Espagne
05/04/2017 06:15

how can i try to update the instance without losing data?

twanda AG, Ermin Trevisan Suisse
05/04/2017 06:23

Sorry, but this goes already far beyond my capacities. Do a system image, make a backup of the database, do the update (be sure you know how to do that), hope and pray.

Borja Espagne
05/04/2017 07:18

Thanks anyway Ermin.

Poser une question
Writer
Keep Informed
1 Abonné(e)s
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now