Help

0

[Ubuntu 16.04]How to install SASS for Odoo

Avatar
Ermin Trevisan

There are many ways to achieve this, but what is a working way for non-deep-techies?

2 Comments
Avatar
Discard
Avatar
Raaj Mishra
-

HI Ermin,pls check below url, may be its helpfull for you.

https://doc.odoo.com/install/

Avatar
Ermin Trevisan
-

No, not really. I'm talking about SASS compiler, as the title says.

2 Answers
2
Avatar
Ermin Trevisan
Best Answer

The problem installing SASS for Odoo is the installation of the proper versions of the corresponding components.

The following components should be installed:

  1. Ruby Version 2.2 (my recommendation, it must be 2 or higher, default Ubuntu deb is 1.9!)

  2. SASS Version 3.4.25 (as implemented by compass, must be >= than 3.3.4)

  3. compass (requires SASS >= 3.3.0 and < 3.5)

  4. bootstrap-sass

An easy way to accomplish this is the following:

Get the Brightbox repository to install the Ruby version you like:

$ sudo apt-get install software-properties-common
$ sudo apt-add-repository ppa:brightbox/ruby-ng
$ sudo apt-get update

Then install Ruby 2.2:

$ sudo apt-get install ruby2.2 ruby2.2-dev

After that you can install SASS 3.4.25:

$ sudo gem install sass -v 3.4.25

and finally install compass and bootstrap-sass:

$ sudo gem install compass bootstrap-sass


Done.

SASS is needed for certain website modules. Here is a further reading: https://github.com/OCA/maintainer-quality-tools/pull/465

1 Comment
Avatar
Discard
Avatar
Divya Vyas
-

@ermin

I followed the same step but still i couldn't install odoo12

Could not execute command 'sassc'This error occured while compiling the bundle 'web.assets_frontend' containing