Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

5

XmlHttpRequestError in web-client when connecting via IP

By
Laurens
on 3/19/13, 10:42 AM 12,370 views

Foreword (Read for background info)

So first off, I am running my OpenERP server on a Windows Server 2003 machine. This Windows Server 2003 is a virtual machine hosted on the network. I can work on the web-client smoothly when connected remotely to the IP adress of the virtual machine, when working this way I never face any issues.

I can also access the web-client from my local machine when I'm either connected to the network, or connected by VPN, and enter the IP address + port in my webbrowser. Initially everything seemed to be working properly, but then I kept facing the same error-prompt.

A big white window reading: "XmlHttpRequestError". I noticed I sometimes encountered this error message in a certain menu, and another moment I wouldn't face that error in the same menu. After some extensive web-searching and testing I was able to deduce this is related to a proxy read time-out. Namely if the server, or web-client, takes too much time to process information/data - it will throw up this error-message instead.

Question

Solution to my problem: increase the proxy_read_timeout from the default 60 seconds to a higher value. It is well documented how to do this for Openerp 6.1, and linux Openerp 7 distro's; but I can't find any information whatsoever on how to do this in a windows environment.

I found out I need to add configuration line “proxy_read_timeout 300;” somewhere after the first string “location” in “/etc/nginx/sites-available/openerp” file.

Problem being I have no such location/ file under my OS. If anyone could explain me in which windows file I could make the necessary changes, I would very much appreciate that gesture. So far I've tried editting the openerp-server.conf and postgresql.conf file but my changes brought no change.

Hi Sir, In my case, disable antivirus avast was the problem. Configure a exception...

Tomás Pascual
on 1/14/14, 10:37 AM
1
John
On 5/7/13, 1:53 PM

Hello,

I've read your messages...I don't know how you work but have you already try to see paramerters of your server into the ".conf"? maybe it jump because one of your limit is passed out or something else?

I'am intersting by the solution.

hope it helps

@John: This is very much possible. A lot of the settings in my postgresql.conf file are unchecked when I look at it through Pgadmin's interface. I'm not sure which setting corresponds with what I'm trying to accomplish: increase the amount of time a page is permitted to load before a time-out. That is what I assume is causing the issue.

If you have some time, I'd appreciate it if you could take a look through my settings and let me know if you see anything odd. Respond whenever is convenient for you. No rush.

Part 1: http://i.imgur.com/URSkguk.png Part 2: http://i.imgur.com/qcbdm3E.png

Laurens
on 5/8/13, 7:44 AM

Hello, I 've just ended to compare your files and mine, it's seems there arn't differences between both...But I am on ubuntu v12 ...your error is maybe due to an other problem. Or maybe other configurations settings...let's try to take a look of your .conf open erp server there are time settings there too...An other solution ll be to intall into an other vm and see if the problem reappears.

John
on 5/8/13, 8:16 AM

I am running on Windows server 2003, which is why it is more difficult to find a solution to this issue. Documentation for OpenERP under windows is very sparse. Still, apart from this ocassional error it is running very smoothly for this small buisness, and I'm not inclined to switch to Ubuntu just because of this. (Although I know there are FAR more benefits. For sure.)

Thank you for taking the time to compare our configuration files. I have updated my answer above to include my openerp-server.conf parameters.

Thank you for taking an interest in my case.

Laurens
on 5/8/13, 9:07 AM

Pratically the sames....actually the same except port and ip...but I maybe have an idea...I think the problem doesn't come from the openn erp or postgres time out but the transmission of the ip paquet maybe you should increase the size of the paquet/time or something like this...

John
on 5/8/13, 9:26 AM
1
Alejandro
On 2/28/14, 3:41 AM

Something about this ?

I have the V7 on a dedicated server and a lot of times I'm getting the XmlHttpRequestError. I need to refresh the screen severeal times to get a good request.

1

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 2/28/14, 9:28 AM

Hi;

Just some ideas :

1_ Did you setup a Domain under windows 2003 server or not: If so, review your network configuration for each machine in the network (especially the default Gateway, DNS1,and DNS2)

2_ In your openerp-server.conf: Increase the following values: limit_time_cpu, limit_time_real.

3_ Postgres Optimization and Tuning:

  https://lists.launchpad.net/openerp-community/msg00762.html

  http://www.varlena.com/GeneralBits/Tidbits/annotated_conf_e.html

  http://linuxfinances.info/info/quickstart.html

  http://wiki.postgresql.org/wiki/Performance_Optimization

  http://www.varlena.com/GeneralBits/Tidbits/perf.html

Hardware resources for Host & Guest systems, The VM, Postgres, and physical network : Tips and Tricks

The hardware characteristics of your Host Machine, impact surely and deeply on the performance of your OpenERP server. (Refer to windows and VM systems requirements) Adjust the hardware resources to meet the minimum requirements (More will be better).

1_ Take care of the Host and guest Systems Requirements of the VM, for OpenERP and for Postgres.

2_ Don't install unnecessary components for your host and guest systems (e.g active directory ...)

3_ Avoid running unused and unnecessary services on your host and guest systems

4_ Avoid running the "Server application" and the "Database Engine" on the same machine.

5_ Run OpenERP on Linux (if possible)

6_ Remember that for Wifi connections: protections as WPA WEP ... Induce an overload ...

7_ Also for wired network: Access Filtering ( by IP or By MAC ...) induce an overload ...

All the above, taken partially or globally, can lead to "Time Out" issues.

The above is far to be an exhaustive list of recommendations !

You can find better and more on the Web.

It's just a contribution, cause we are all facing (from time to time) the same "Performances" issues.

Best regards.

0
Rebel
On 3/19/13, 12:30 PM

I have the same problem under Windows 7, have you found the solution?

No, I haven't found the solution yet; but I've been continueing development remotely on the virutal machine. I have tried a couple of things, but none have seemed to fix it.

I have noticed that on some faster computers in the network the "XmlHttpRequestError" doesn't or barely shows up. On the older machines, and those using up more CPU %, the error is more frequent. I'm pretty sure it's related due to a timeout, and that the page fails to load when the processing is taking too long.

I really wish I could find the right setting to increase the proxy_read_time for OpenERP 7 under Windows

Laurens
on 3/20/13, 5:24 AM
0
MAK AUVIA
On 5/27/14, 4:36 AM

I am running OpenERP v8 over mod_wsgi apache2.4 Ubuntu 14.04 and i had same problem.

The problem solved when i changed the KeepAliveTimeout in apache setting file /etc/apache/apache.conf

Change "KeepAliveTimeout 5" to "KeepAliveTimeout 10"

0
Laurens
On 3/20/13, 5:23 AM

No, I haven't found the solution yet; but I've been continueing developpment remotely on the virutal machine. I have tried a couple of things, but none have seemed to fix it.

I have noticed that on some faster computers in the network the "XmlHttpRequestError" doesn't or barely shows up. On the older machines, and those using up more CPU %, the error is more frequent. I'm pretty sure it's related due to a timeout, and that the page fails to load when the processing is taking too long.

I really wish I could find the right setting to increase the proxy_read_time, but none of the articles and documentation I have come across describe how to alter this setting for OpenERP 7 under a Windows OS.

0
Laurens
On 5/7/13, 12:38 PM

I still have the same problem, though it is work-able. While working with cable connection, this error barely ever show up - only sometimes when loading large lists. When connected wirelessly, this will pop up a bit more often. I'm quite sure it's related to the time the page needs to load.

@John:

I'll paste the settings of my openerp-server.conf file here. I do not have enough space in a comment to list them there.

[options]

without_demo = False

unaccent = False

db_template = template1

db_password = xxxx

xmlrpcs = True

xmlrpcs_interface =

syslog = False

logrotate = True

xmlrpcs_port = 8071

test_report_directory = False

list_db = True

timezone = False

xmlrpc_interface =

test_file = False

smtp_password = False

secure_pkey_file = server.pkey

xmlrpc_port = 8069

workers = 0

log_level = info

xmlrpc = True

admin_passwd = xxxxx

smtp_port = 25

smtp_server = localhost

static_http_url_prefix = None

limit_request = 8192

test_commit = False

proxy_mode = False

demo = {}

dbfilter = .*

login_message = False

import_partial =

pidfile = None

db_maxconn = 64

osv_memory_count_limit = False

reportgz = False

osv_memory_age_limit = 1.0

netrpc_port = 8070

db_port =5432

db_name = False

debug_mode = False

netrpc = False

limit_time_real = 120

limit_memory_hard = 805306368

logfile = C:\Program Files\OpenERP 7\Server\server\openerp-server.log

csv_internal_sep = ,

limit_time_cpu = 60

pg_path =C:\Program Files\OpenERP 7\PostgreSQL\bin

limit_memory_soft = 671088640

static_http_enable = False

translate_modules = ['all']

smtp_ssl = False

server_wide_modules = None

netrpc_interface =

smtp_user = False

log_handler = [':INFO']

db_user =openpg

db_host =192.168.100.3

test_enable = False

max_cron_threads = 2

static_http_document_root = None

email_from = False

addons_path = C:\Program Files\OpenERP 7\Server\server\openerp\addons

secure_cert_file = server.cert

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 3/19/13, 10:42 AM
Seen: 12370 times
Last updated: 5/12/16, 3:35 PM