Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

XmlHttpRequestError in OpenERP7

By
Vikas Sinha
on 6/16/14, 12:59 PM 1,064 views

When we try to extract a report, after around 8 min of page loading, OpenERP threw this error without any information logged in the logs. Strange behaviour is that, it is working fine from one location (e.g Germany) but not working at all from India location.

 

Header

  1. Request URL:

    http://abc.xyz.com/web/dataset/call_button

  2. Request Headers CAUTION: Provisional headers are shown.
    1. Accept:

      application/json, text/javascript, */*; q=0.01

    2. Content-Type:

      application/json

    3. Origin:

      http://abc.xyz.com

    4. Referer:

      http://abc.xyz.com/?ts=1402926007810

    5. User-Agent:

      Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

    6. X-Requested-With:

      XMLHttpRequest

  3. Request Payloadview parsed
    1. {"jsonrpc":"2.0","method":"call","params":{"model":"cell_specific.export","method":"export_xls","domain_id":null,"context_id":1,"args":[[1138],{"lang":"en_US","tz":"US/Eastern","practice_id":false,"ea":false,"practice_name":false,"on_behalf_id":false,"last_login":false,"custo_group_level":3,"full_name":"Vikas Sinha","partner":false,"partner_uid":1551,"ea_access":false,"uid":1551}],"session_id":"4d2187fc61464d1fb1e0978dbb74aa38","context":{"lang":"en_US","tz":"US/Eastern","practice_id":false,"ea":false,"practice_name":false,"on_behalf_id":false,"last_login":false,"custo_group_level":3,"full_name":"Vikas Sinha","partner":false,"partner_uid":1551,"ea_access":false,"uid":1551}},"id":"r42"}
0
William Brugger
On 3/3/16, 7:46 PM

Depending on your server, you may be able to change the time-out.   For example if you use nginx, you could change (or add) the

proxy timeouts to something longer than 8 minutes.  For example 10 minutes.  Not sure if all of these are needed, but definity the proxy_read_timeout should be adjusted.


proxy_connect_timeout 600;
proxy_send_timeout 600;
proxy_read_timeout 600;
send_timeout 600;

I'm sure apache has similar settings.


In my case I don't use ngix or apache or any www server, is the default web server from openerp. I still don't fix this issue, I had try different values from openerp-server.conf and no luck, some people had told me the say answer about ngix but is not my case, any more will be appreciated.

klabacita
on 3/23/16, 1:57 PM
0

Cameron

--Cameron--
769
| 6 5 8
United Kingdom
--Cameron--
Cameron
On 3/3/16, 5:36 PM

My experience of his error - is it is cause by a lack of Bandwidth! 


Sorry, Im sure that doesnt help :(

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 6/16/14, 12:59 PM
Seen: 1064 times
Last updated: 3/3/16, 7:46 PM