Odoo Help


xmlhttprequesterror from opernerp v7.0 on ubuntu

Praveen Karoshi
on 3/17/14, 7:38 AM 6,726 views


I have installed openerp v7.0 on ubuntu 10.04 with python 2.6. I get xmlhttprequesterror during menu operations. I do not have nginx or any other reverse proxy server installed. The openerp-server is run from an external server hosting ubuntu and accessed through firefox web browser running on ubuntu machine. If this error is from timeout where should I update the timeout parameter. If not, how to solve this error.

Everytime xmlhttprequesterror occurs we have to restart the openerp-server which is annoying. Please help!

Dieter Huelskamp
On 3/28/15, 4:35 PM

I have the same issue with Odoo v. 8 using 1GB Memory plan at digital ocean. (already much faster than free amazon t1 tier coming with 750 MB of memory). Anyone an idee, where to find such config file for odoo 8? Or description of precedure in order to fix that kind of error?


Med Said BARA

--Med Said BARA--

| 5 5 7
--Med Said BARA--
Med Said BARA
On 3/17/14, 9:53 AM


Check your Firewall settings.

Try to connect with another browser.

Check your Anti-virus config (Deactvate it to see if it's the cause)

If you are using a proxy, check your config

If you are using Multiprocessing (eg. workers = x) in your openerp-server.conf, try to increase limit_time_cpu = and limit_time_real =

Resp. to comment

There is no secrets in the openerp-server.conf (except the password).

Just copy paste the content of your openerp-server.conf in your message or attach your file.

Post also the content of your openerp-server.log or attch it.

The following is an example of openerp-server.conf, don't try to use it as it is. Cause many options inside it, are specific to the real configuration of the running "OpenERP" instance.


addons_path = /usr/lib/pymodules/python2.7/openerp/addons

admin_passwd = admin

assert_exit_level = error

cache_timeout = 100000

csv_internal_sep = ,

db_host = False

db_maxconn = 64

db_name = False

db_password = my_db_password

db_port = False

db_template = template1

db_user = openerp

dbfilter = .*

debug_mode = True

demo = {}

email_from = False

ftp_server_host =

import_partial =

limit_memory_hard = 805306368

limit_memory_soft = 671088640

limit_request = 8192

limit_time_cpu = 180

limit_time_real = 240

list_db = True


#log_level = debug

logfile = /var/log/openerp/openerp-server.log

login_message = False

logrotate = True

max_cron_threads = 4

netrpc = True

netrpc_interface =

netrpc_port = 8070

osv_memory_age_limit = 1.0

osv_memory_count_limit = False

pg_path = None

pidfile = False

proxy_mode = True

reportgz = False

secure_cert_file = server.cert

secure_pkey_file = server.pkey

server_wide_modules = None

smtp_password = False

smtp_port = 25

smtp_server = localhost

smtp_ssl = False

smtp_user = False

static_http_document_root = None

static_http_enable = False

static_http_url_prefix = None

syslog = False

test_commit = False

test_disable = False

test_enable = False

test_file = False

test_report_directory = False

timezone = False

translate_modules = ['all']

unaccent = False

without_demo = False

#workers = 2

xmlrpc = True

xmlrpc_interface =

xmlrpc_port = 8969

xmlrpcs = True

xmlrpcs_interface =

xmlrpcs_port = 8071

#gevent = True

longpolling_port = 8072


dir_path = /usr/lib/pymodules/python2.7/openerp/addons/document_webdav/public_html


enable = True

vdir = webdav

If the error is eally related to time-out, try to increase limit_time_cpu = and limit_time_real = (to 120 or 160 ....)

Try browsing with Chrome.

There is no firewall or anti-virus on the ubuntu machine i m using nor the network. As for config file, its present in the install/ directory of source code after setup.py install. Can you provide with a sample config file for openerp 7 on linux? Dont think the config file is being used by our installation. Why does the server crash if there is Xmlhttprequesterror on client side?

Praveen Karoshi
on 3/17/14, 10:04 AM

[options] ; This is the password that allows database operations: ; admin_passwd = admin db_host = localhost db_port = false db_user = false db_password = false

Praveen Karoshi
on 3/17/14, 12:29 PM

i made changes to conf file, the openerp-server.log file does not show any error, but the xmlhttprequesterror still occurs and server has to be restarted.

Praveen Karoshi
on 3/20/14, 4:24 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 3/17/14, 7:38 AM
Seen: 6726 times
Last updated: 12/22/15, 10:40 PM