Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


wkhtmltopdf 0.12.1-1.el7 not working properly on CentOS7 - generates 0 byte files

on 8/3/16, 5:10 PM 245 views

Hi All,

it seems my issue for wkhtmltopdf is quite wierd.

CentOS7 have wkhtmltopdf version 0.12.1-1.el7, i can get the html just fine but when i switch it to pdf its not working i get 0 bytes.

I've seen this behavior with  others , but the solution was to upgrade to 0.12.1-1.el7. Although im already at this version ahs anyone seen this behavior?


Giezel Esteves
On 8/3/16, 10:57 PM

Please try this one


Please follow this steps

1) Download wkhtmltopdf version from wkhtmltopdf.org depend on your system arch (32 or 64 bit)

wget wget \http://downloads.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-amd64.deb

2) Install the package using commnad :

sudo dpkg -i wkhtmltox-0.12.1_linux-trusty-amd64.deb

3) Copy binary or wkhtmltopdf to /usr/bin location from ./usr/local/bin use command

sudo cp /usr/local/bin/wkhtmltopdf /usr/bin/

4) Restart Odoo server and try once again.


Stephan Bleh
On 8/6/16, 11:55 AM

How I solved that problem with Centos 7:

wget http://download.gna.org/wkhtmltopdf/0.12/0.12.1/wkhtmltox-0.12.1_linux-centos7-amd64.rpm

rpm -ihv wkhtmltox-0.12.1_linux-centos7-amd64.rpm

All other versions didn´t worked correct. Please deinstall the "centos"-version of wkhtmltox.



Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 8/3/16, 5:10 PM
Seen: 245 times
Last updated: 8/6/16, 2:31 PM