Help

12

widget="progressbar" in Kanban view

Avatar
Ameera PP

I tried <field name=progress_rate" widget="progressbar"/> in kanban view.. It just showing the value instead of progressbar . Why widget="progressbar" not supporting in kanban view..Its supporting in form view and tree view. Is there any way to show the progressbar in kanban view?


2 Comments
Avatar
Discard
Avatar
Odoo Mates
-
2 Answers
9
Best Answer

Hi Ameera,

Try  widget gauge

For example Create two integer fields  

progress_rate = fields.Integer()
maximum_rate = fields.Integer()

Set widget="gauge" and  max_field is other field

<field name="invoiced_target" widget="gauge" style="width:120px;height:90px;cursor:pointer;" 
options="{'max_field': 'maximum_rate'}">
Progress
</field>


Example Code

<kanban>
    <field name="progress_rate"/> 
    <field name="maximum_rate"/>  
        <templates> 
            <t t-name="kanban-box">
                <div class="oe_kanban_global_click">  
                    <field name="progress_rate" widget="gauge" style="width:120px;height:90px;cursor:pointer;" 
                           options="{'max_field': 'maximum_rate'}"> 
                                   Progress                               
                    </field>                           
                </div>     
             </t>
        </templates>
</kanban>



4 Comments
Avatar
Discard
Avatar
Ameera PP
-

Thanks Shameem

Avatar
Nilmar Shereef
-

Good Shameem.. You have an up vote

Avatar
Bonnet Denis
-

can you tell us on wich ODOO version this widget is usable? thx

Avatar
Shameem Babu @ iWesabe
-

It is working in odoo 8 and odoo 9

1
Avatar
Hilar AK
Best Answer

+1 Shameem

Avatar
Discard