Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Why OpenERP 7.0 on Ubuntu 12.04 server(amd64) doesn't work after reboot?

Koali Soluciones Informáticas
on 7/1/13, 4:57 PM 3,261 views

Hello all.

I'm trying to set up an OpenERP 7.0 server for a startup company that I've just launched and I always have this same problem whenever I try.

First I've tried to simply "apt-get install" openERP from the nightly repo that is shown on the web. Installation ended. Does not work. Later I've tried to remove that installation(apt-get purge) and reinstall from the sources(also from the repo shown in the web) following a pretty nice tutorial on TheOpenSourcerer. It worked, I was able to set up some things, users, create databases and a few more things. Then I rebooted the virtual machine that is hosting the service and never worked again.

On both cases it shows the exactly same error on prompt, but I can't figure it out how to fix it. Can anybody help?

This is the transcription of the error:

2013-07-01 18:31:45,800 1539 INFO ? openerp.addons.google_docs.google_docs: GData lib version '%s GData-Python/2.0.18' detected
Exception in thread Thread-1:
Traceback (most recent call last):
     File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
     File "/usr/lib/python2.7/threading.py", line 504, in run
          self.__target(*self.__args, **self.__kwargs)
     File "opt/openerp/server/openerp/service/wsgi_server.py", line 436, in serve
          httpd = werkzeug.serving.make_server(interface, port, application, threaded=True)
     File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 399, in make_server
          passthrough_errors, ssl_context)
     File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py" line 331. in __init__
          HTTPServer.__init__(self, (host, int(port)), handler)
     File "/usr/lib/python2.7/SocketServer.py", line 408 in __init__
     File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
     File "/usr/lib/python2.7/SocketServer.py", line 419, in server_bind
     File "/usr/lib/python2.7/socket.py", line 224, in meth
          return getattr(self._sock, name)(*args)
error: [Errno 98] La dirección ya se está usando

2013-07-01 18:31:46, 028 1539 INFO ? openerp: OpenERP server is running, waiting for connections...

The last line in the error description is in spanish because that is the default language of that machine, that translates into:

error: [Errno 98] That address is already in use

The server response says that is ready and waiting, but doesn't show anything on the browser, so... I figure that is not true then.

I've reviewed every step I've done, every file I've written, everything I could imagine, but I can't fix it.

Also at the momento I'm writing this I've realized that the clock on that transcription says 18:31 when here it is 20:31. Since I didn't realized ever before an AMD could time travel I think that could be somewhat related to the error.

I hope somebody could help me to get this server going again and thanks to everyone beforehand.


AJ Schrafel Paper Corp

--AJ Schrafel Paper Corp--
| 4 5 8
Bronx, United States
--AJ Schrafel Paper Corp--

Exploring OpenERP for business

AJ Schrafel Paper Corp
On 7/1/13, 6:51 PM

look at the process running. If there are 2 instances of openERP they could be messing each other up.

try stopping the server - type ps aux | grep openerp to confirm you stopped the server, then start the server again.

If that doesn't solve the problem you will have to figure out what other program is using that port and shut it down/ get it to use a different port.

Thanks, that was the problem.

I thought that starting the service after reboot would throw an exception if the service was already on, but it didin't, so that made the service to start twice and crash.

Thanks again, it is restablished again.

Koali Soluciones Informáticas
on 7/8/13, 7:36 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 7/1/13, 4:57 PM
Seen: 3261 times
Last updated: 3/16/15, 8:10 AM