Odoo Help

0

Why not all model fields shown in defalt view?

By
Roman
on 2/22/16, 7:07 AM 429 views

todo_view.xml:

<?xml version="1.0"?>
<odoo>
 <record model="ir.actions.act_window" id="action_todo_task">
 <field name="name">To-Do Task</field>
 <field name="res_model">todo.task</field>
 <field name="view_mode">tree, form</field>
 </record>
 <menuitem id="main_menu_todo_task" name="To-Do App" />
 <menuitem id="menu_todo_task" name="To-Do Task" parent="main_menu_todo_task"/>
 <menuitem id="todo_task_menu" name="Tasks" parent="menu_todo_task" action="action_todo_task"/>
</odoo>

todo_model.py:

# -*- coding: utf-8 -*-
from openerp import models, fields
class ToDoTask(models.Model):
 _name = "todo.task"
 name = fields.Char('Descrition', required = True)
 is_done = fields.Boolean('Done?')
 active = fields.Boolean('Active?', default = True)

When I go to view, there is only 'Description' and one checkbox without title.

 

0

Ankit H Gandhi(AHG)

--Ankit H Gandhi(AHG)--
1081
| 5 3 6
Rajkot, India
--Ankit H Gandhi(AHG)--

Learning Python..

Ankit H Gandhi(AHG)
On 2/23/16, 3:17 AM

Dear Roman,

You need to create new form view and define all the fields then after you will show fields.

without create form view, you can show only name field.

Cheers,

Ankit H Gandhi.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 2/22/16, 7:07 AM
Seen: 429 times
Last updated: 2/23/16, 3:17 AM