Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Why my Invoice report translation is not working?

By
Pavel Pavlov
on 1/25/14, 1:07 PM 2,400 views

Hi,

I'm struggling to translate my invoice... For example I see that I already have in the database the translation for "Invoice Date" under "Translated Terms": http://imageshack.com/a/img17/5375/2ojy.jpg image description

Then I add this string to my account.invoice RML via Open Office http://imageshack.com/a/img17/5375/2ojy.jpgimage description

But still, when I print the document the string is not being translated and I see "Invoice Date". While for example the string "Invoice", "Taxes:", "Quantity" and other are being exchanged properly to my language. What am I doing wrong?

Regards,
Pavel Pavlov

1
Pavel Pavlov
On 1/25/14, 1:25 PM

Hi,

I've found another way to go around this issue thanks to the information in https://accounts.openerp.com/forum/Help-1/question/20329/ . I just created in my custom module i18n\bg.po and <module>.pot and added for simple test in both files following content, which after updating the module translated properly in the invoice

#: report:account.invoice:0
msgid "ORIGINAL"
msgstr "ОРИГИНАЛ"

Still the question is open - why the change I did to the database was not working?

Regards, Pavel

0
klacus
On 1/26/14, 12:49 AM

May you have a problem with the object linking, name or id problem. Check the postgres db with pgadmin, or phpPgAdmin, you can see the diffs. You can compare the name and id in your transaction.

I think your translation is in the system, just you miss the id, or your system is not exists this items...

Hello, looks like I have to do Settings -> Translations -> Application Terms -> Synchronize Terms, before I can see the changed translations in my report... after I restart openerp, update my module, Synch Terms, then it works as I expect. Maybe this is how it should work - don't know... couldn't find doucmentation on that.

Pavel Pavlov
on 1/30/14, 6:39 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/25/14, 1:07 PM
Seen: 2400 times
Last updated: 3/16/15, 8:10 AM