Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Why isn't logging working?

Michael Scorpio
on 10/25/15, 3:55 PM 701 views

I'm trying to log sql events to the ir_logging table. My config is as follows;

log_db = True
log_db_level = warning
log_handler = :INFO
log_level = debug_sql
logfile = /var/log/odoo/odoo-server.log
logrotate = False

I've also tried "info" for the log_db_level parameter and restarted the odoo service before each test. I've created sales orders and performed stock moves, but had zero rows written to the ir_logging table. I can't find this properly documented anywhere. How does it work?


Ray Carnes

--Ray Carnes--
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 10/25/15, 5:06 PM


--log-db <dbname>

logs to the ir.logging model (ir_logging table) of the specified database. The database can be the name of a database in the "current" PostgreSQL, or a PostgreSQL URI for e.g. log aggregation

Is your database named 'True' ?

Bista Solutions US, Ray Carnes
on 10/25/15, 5:06 PM
Michael Scorpio
On 10/26/15, 5:30 AM

@Ray; thanks, the only documentation I could find (http://www.mindissoftware.com/2014/09/07/Odoo-logging-configuration-usage-implementation/) had log_db as True and given that is was originally False in my config, this sounded reasonable. I've changed it to the name of my database, and I'm getting some logging, but not logging of SQL statements. Tried a number of things including setting the log_handler = openerp.sql_db:DEBUG. Still no SQL logging.

I have always used "log_level = debug_sql"

Bista Solutions US, Ray Carnes
on 10/26/15, 11:07 PM


| 5 4 6
Zagreb | Karlovac, Croatia

there is only 10 kind of people the ones that understand binary ... and others

On 10/26/15, 4:39 AM

also.. try this setting :

log_level  = :DEBUG

will output more log messages...

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 10/25/15, 3:55 PM
Seen: 701 times
Last updated: 10/26/15, 5:30 AM