Odoo Help

0

Why is the Quote "counter" ticking even if there is no quote made.

By
Mats Kjellberg
on 7/25/13, 2:24 PM 875 views

Hi,

Why is the Quote counter ticking (changing) as soon as you press the quote button. It ticking even if you don't write and save a quote, you just need to press the quote button and the step back and it's an new no. for next quote.. Why is it like this, and is there any way to change this..?

And how are you able to reset the counter to start for one again..

Note, all this apply even for sales order etc.

Please help any one to fix this..? /M

1

Ray Carnes

--Ray Carnes--
16369
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0; Odoo 8.0, 9.0, 10.0.

Completed Odoo Functional and Technical Training.

Major Skills:

  • User Needs and GAP Analysis;

  • Functional and Technical Design;

  • Prototyping and Proof of Concepts;

  • Requirements Specifications;

  • Agile Implementation;

  • Data Migration;

  • Configuration & Customization (UI and code);

  • Integration - Odoo and non Odoo Applications and Services;

  • Training and Knowledge Transfer;

  • Go Live Support;

  • Helpdesk;

  • Version Upgrades and Migration.

  • Accounting Expert.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

I am a skilled Communicator and I only take the serious things seriously!

Ray Carnes
On 7/25/13, 5:29 PM

This is to support multiple people pressing the quote button at the same time and guarantee they will all have unique numbered quotes when they save.

Sequences are maintained via the menu sequence:

Settings --> Technical --> Sequences and Identifiers --> Sequences.

Thanks I have found and tried this, but I'm not able to save the new number that i have entered, when you pres save and look again it's the same high no..? Any solution for this?.. And would there be any "bypass" workaround to disable the function for security that you described above?

Mats Kjellberg
on 7/25/13, 6:02 PM
0

Grover Menacho

--Grover Menacho--
2533
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Systems Engineer + MBA

Grover Menacho
On 7/25/13, 6:27 PM

Are you doing that in 6.1? Because as I know in v7.0 that's not happening anymore.

Anyways I can explain you. When you see the code of sale.order. there is _defaults={} and there is calling the get funcion of ir.sequence. That's why when you open a new form even if you are not saving that it's automatically incremented.

You can change it by code so it's not going to happen. Maybe you can override the write and there you can assign the new sequence.

Yes I'm using version 7..

Mats Kjellberg
on 7/25/13, 6:55 PM

The big question is still how to reset it so it starts from 1 again, the above location of the setting seams to be correct but I'm not able to change the new setting.

Mats Kjellberg
on 7/25/13, 7:04 PM

That's strange, usually you can change the next_number in sales order. When you save it, does it return to the old number?

GH Mediacloud, Grover Menacho
on 7/25/13, 7:15 PM

Yes, exactly..

Mats Kjellberg
on 7/25/13, 7:19 PM
0
Mats Kjellberg
On 7/25/13, 6:55 PM

Hi, Yes I'm using version 7..

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 7/25/13, 2:24 PM
Seen: 875 times
Last updated: 3/16/15, 8:10 AM