Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Why does it say "Uncaught Record not correctly loaded" When creating password?

By
Tyler Christensen
on 3/1/14, 5:42 PM 2,801 views

When i create a user and try to change the password it gives this error "Uncaught Record not correctly loaded" and then when i hit okay, the program won't load anything. all lists are blank. why is this? what can i do about it?

Do you have more informationn in your OpenERP server logs?

Youri
on 3/2/14, 9:37 AM

where do i get those logs? i am a newbie with this.

Tyler Christensen
on 3/4/14, 9:05 PM

/var/log/openerp

Youri
on 3/5/14, 12:53 AM

First, check if the password is created or not.Then post your log

Med Said BARA
on 3/5/14, 6:19 AM

Applying http://bazaar.launchpad.net/~openerp/openobject-server/saas-2/revision/5017 to the 7.0 branch worked for me!

Yann Bongiovanni
on 3/13/14, 7:33 AM
0
Sharif Sayfulloev
On 3/13/14, 2:17 PM

Hi

I also was affected by this

Here is comitted bug for saas-2 and saas-3 bugs.launchpad.net/openobject-server/+bug/1280148 (not enough karma to publish links :(( )

As Yann advised you can apply this revision: bazaar.launchpad.net/~openerp/openobject-server/saas-2/revision/5017#openerp/addons/base/res/wizard/change_password_wizard.py

In /usr/lib/pymodules/python2.7/openerp/addons/base/res/wizard/change_password_wizard.py file (assuming that you are using Debian/Ubuntu installation) On line 58

change:

self.pool.get('change.password.user').unlink(cr, uid, user_ids)

to this:

self.pool.get('change.password.user').write(cr, uid, user_ids, {'new_passwd': False})

restart openerp-server and now you can change passwords.

Regards Sharif

I have the same problem in trunk... version openerp-8.0dev_20140312_000101... but I can't find this wizard in base module... Do you know where it is? I'm using debian, installed via aptitude. Tks.

Eloi Bermejo
on 3/19/14, 5:23 AM

for openerp8 change.password.wizard is in /addonos/base/res/res_users.py , and the row to change is 911 . I tried the above patch and porblem seem to be solved. hope to be useful.

adriano
on 4/4/14, 9:46 AM

Adriano - Thanks the above line replacement resolved the issue on V8

Zeeshan Shafqat
on 4/28/14, 11:43 AM
0
gustavo
On 6/8/14, 8:49 PM

Please explain the fix to use in windwos server 2008

thanks

Gustavo

0
Tyler Christensen
On 3/4/14, 9:04 PM

I am a newbie. Where do i get those logs?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 3/1/14, 5:42 PM
Seen: 2801 times
Last updated: 3/16/15, 8:10 AM