Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Why can't I start my server?

By
Jeff Beidler
on 1/28/15, 4:41 PM 854 views

I started getting this error today, when I try to start my server:

ParseError: "ValidateError
Field(s) `arch` failed against a constraint: Invalid view definition

Error details:
Field `menu_id` does not exist

Error context:
View `res.users.groups`
[view_id: 159, xml_id: base.user_groups_view, model: res.users, parent_id: 156]" while parsing /home/openerp/odoo-8.0-20150128/openerp/addons/base/base_data.xml:88, near
<record id="group_portal" model="res.groups">
            <field name="name">Portal</field>
            <field name="comment">Portal members have specific access rights (such as record rules and restricted menus).
                They usually do not belong to the usual Odoo groups.</field>
        </record>

I downloaded the latest nightly build (1-28), but the error persists.  I can't even access the login screen!  All I get is a "500 Internal Server Error" and the above message at the command line.  If this is a problem in base, how do I get up and running again?

Have you upgraded your database after the change in code?

Bista Solutions US, Ray Carnes
on 1/28/15, 7:06 PM

I ran "odoo.py --addons='myaddons_dir' -u all -d my_db_name" for each of my databases. Is there a different way?

Jeff Beidler
on 1/28/15, 7:31 PM

I tried to re-run the command, but the process seems to hang up at this point: "2015-01-29 00:35:24,401 11371 INFO JDE-2 openerp.modules.loading: 70 modules loaded in 153.44s, 0 queries 2015-01-29 00:35:25,866 11371 INFO JDE-2 openerp.modules.loading: Modules loaded. 2015-01-29 00:35:25,874 11371 INFO JDE-2 openerp.models: Computing parent left and right for table ir_ui_menu..."

Jeff Beidler
on 1/29/15, 11:26 AM
0
Jeff Beidler
On 1/30/15, 11:34 AM

It seems that when the "-u all -d db_name" update got hung up, something got corrupted in the older databases.  As this was only on my dev sandbox and I didn't need to preserve any data, I just went in to the psql program and dropped the databases, leaving the one that was created with the newer code base.  Problem solved instantly.

0
Gaurav Sahu
On 1/29/15, 11:51 PM

Try this
./openerp-server  --addonse-path=<path>  -u base -d <database>

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/28/15, 4:41 PM
Seen: 854 times
Last updated: 3/16/15, 8:10 AM