Odoo Help

1

Why am I getting 502 error with longpolling?

By
Prowler
on 3/23/16, 5:10 AM 1,614 views

Hello. Newby here..

I have nginx proxy_pass directed to port 8069. Also another proxy pass for location /longpolling points to 8072. I think it's all fine on the nginx side. The problem is (I think) that longpolling is not working at all.

This is the output from firebug console:

POST https://example.com/longpolling/poll 502 Bad Gateway 2ms

I think my problem is the same as this guy's:

http://stackoverflow.com/questions/30161575/odoo-on-debian-longpolling-port-is-never-used-opened

I can telnet to 8069 but not to 8072.

$ telnet 127.0.0.1 8072

Trying 127.0.0.1...

telnet: Unable to connect to remote host: Connection refused

Nobody responded to him and I don't really understand his own answer. This package 'psycogreen' I already had installed.

I pasted my odoo-server.conf file contents here: http://pastebin.com/rSKaLxSV

1
Roel Adriaans
On 3/25/16, 9:38 AM

Use workers with a non zero value, for example 4. Your current value is 0

This will create a longpolling process on port 8072..


That doesn't work.. I'm still getting 502 :(

Prowler
on 3/29/16, 2:34 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/23/16, 5:10 AM
Seen: 1614 times
Last updated: 3/30/16, 7:03 AM