Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


while restarting openerp server i got error: [Errno 98] Address already in use [Closed]

on 10/11/13, 2:54 PM 907 views

The Question has been closed for reason: duplicate question

on 10/11/2013 15:39:53

I have created 2 OpenERP instances in ubuntu 12.04 I have extracted openerp-7.0-latest.tar.gz this file 2 times as folder name openerp-7.0-test1 openerp-7.0-test2 I did changes in both config files having path openerp/tools/config.py I have changed only port numbers for test1 folder Port number is default 8069 and for test2 folder orinstance port number is 8099 when i have started openerp from test1 folder it is running fine. when i opened other terminal to run test2 instance it is showing me following error.

   user@ubuntu:~/openerp-7.0-test2$ ./openerp-server
   2013-10-11 16:11:47,496 15915 INFO ? openerp: OpenERP version 7.0-20130605-231041
  2013-10-11 16:11:47,496 15915 INFO ? openerp: addons paths: /home/user/openerp-7.0-test1/openerp/addons
 2013-10-11 16:11:47,496 15915 INFO ? openerp: database hostname: localhost
 2013-10-11 16:11:47,496 15915 INFO ? openerp: database port: 5432
 2013-10-11 16:11:47,496 15915 INFO ? openerp: database user: fabian
2013-10-11 16:11:47,956 15915 INFO ? openerp.addons.google_docs.google_docs: GData lib version `%s GData-            Python/2.0.14` detected
 Exception in thread Thread-1:
 Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
 File "/usr/lib/python2.7/threading.py", line 504, in run
     self.__target(*self.__args, **self.__kwargs)
 File "/home/fabian/openerp-7.0-castel/openerp/service/wsgi_server.py", line 436, in serve
    httpd = werkzeug.serving.make_server(interface, port, application, threaded=True)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 399, in make_server
    passthrough_errors, ssl_context)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 331, in __init__
     HTTPServer.__init__(self, (host, int(port)), handler)
  File "/usr/lib/python2.7/SocketServer.py", line 408, in __init__
  File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
  File "/usr/lib/python2.7/SocketServer.py", line 419, in server_bind
  File "/usr/lib/python2.7/socket.py", line 224, in meth
   return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

I have tried following command to change addons path but still it is showing me same error

  ./openerp-servver --addons=<path for test2 addons> --config=<path for config file of test2 instance>

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 10/11/13, 2:54 PM
Seen: 907 times
Last updated: 3/16/15, 8:10 AM